PAT (Basic Level) Practice (中文)1044 火星数字

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

AC代码

#include<stdio.h>
#include<stdlib.h>//atoi
#include<string.h>//strcmp,strlen
int main(){
    char mar1[13][5]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
    char mar2[13][5]={"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
    int n;
    scanf("%d\n",&n);
    char temp[11];
    for(int i=0;i<n;i++){
        gets(temp);
        if(temp[0]>='0'&&temp[0]<='9'){//数字转火星文
            int a=atoi(temp);
            int a1=a%13;
            int a2=a/13;
            if(a2!=0&&a1!=0)printf("%s %s\n",mar2[a2],mar1[a1]);
            else if(a2!=0&&a1==0)printf("%s\n",mar2[a2]);//有高位时,低位是0不输出
            else printf("%s\n",mar1[a1]);
        }
        else{//火星文转数字
            int l=strlen(temp);
            if(l==3||l==4){//只有一个单词时
                for(int j=0;j<13;j++){
                    if(strcmp(temp,mar1[j])==0){
                        printf("%d\n",j);
                        break;
                    }
                    if(strcmp(temp,mar2[j])==0){
                        printf("%d\n",j*13);
                        break;
                    }
                }
            }
            else{
                char temp2[5],temp1[5];//高位和低位
                int sum=0;
                for(int j=0;j<3;j++)temp2[j]=temp[j];
                for(int j=4;j<l;j++)temp1[j-4]=temp[j];
                for(int j=0;j<13;j++){
                    if(strcmp(temp2,mar2[j])==0)sum+=j*13;
                    if(strcmp(temp1,mar1[j])==0)sum+=j;
                }
                printf("%d\n",sum);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Dragon_dd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值