Spreading the Wealth( UVA - 11300)

题目链接: Spreading the Wealth

 UVA - 11300 

Problem


A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input


There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output


For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input


3
100
100
100
4
1
2
5
4


Sample Output


0
4
解题思路:这个题目一看到题目感觉不是很复杂,觉得其中应该有一定的数学关系,但是推了一会并没有得出答案,只想到了一个距离的关系。书上这个题目给出的方法十分的好,之前也没有见过这个方法。 
假设对所有的人进行从1到n进行编号,第1个人给第n个人x1枚金币,给第2个人x2金币,第二个人给第一个人-x2枚金币,给第三个人x3枚金币…….. 
从这个方面我们可以得到一个公式 
A1 - x1 + x2 = M -> x2 = M - A1 + x2 = x1 - C1(规定C1 = A1 - M) 
A2 - x2 + x3 = M -> x3 = M - A2 + x2 = 2M - A1 - A2 + x1 = x1 - C2 
…… 
所有的交换金币次数为x1到xn的绝对值的和 
找到中位数即可求的最小值

代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll arr[1000000],brr[1000000];
int main()
{
    ll n;
    while (cin >> n)
    {
        ll sum = 0;
        for (int i = 1; i <= n; ++i)
        {
            cin >> arr[i];
            sum += arr[i];
        }
        ll num = sum / n;
        brr[0] = 0;
        for (int i = 1; i < n; ++i)
        {
            brr[i] = brr[i - 1] + arr[i] - num;
        }
        sort(brr, brr + n);
        ll x1 = brr[n / 2];
        ll ans = 0;
        for (int i = 0; i < n; ++i)
            ans += abs(x1 - brr[i]);
        cout << ans << endl;
    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值