NBUT - 1225 NEW RDSP MODE I

Little A has became fascinated with the game Dota recently, but he is not a good player. In all the modes, the rdsp Mode is popular on online, in this mode, little A always loses games if he gets strange heroes, because, the heroes are distributed randomly.


Little A wants to win the game, so he cracks the code of the rdsp mode with his talent on programming. The following description is about the rdsp mode:


There are N heroes in the game, and they all have a unique number between 1 and N. At the beginning of game, all heroes will be sorted by the number in ascending order. So, all heroes form a sequence One.


These heroes will be operated by the following stages M times:


1.Get out the heroes in odd position of sequence One to form a new sequence Two;


2.Let the remaining heroes in even position to form a new sequence Three;


3.Add the sequence Two to the back of sequence Three to form a new sequence One.


After M times' operation, the X heroes in the front of new sequence One will be chosen to be Little A's heroes. The problem for you is to tell little A the numbers of his heroes.
















Input
There are several test cases. 
Each case contains three integers N (1<=N<1,000,000), M (1<=M<100,000,000), X(1<=X<=20). 
Proceed to the end of file.
Output
For each test case, output X integers indicate the number of heroes. There is a space between two numbers. The output of one test case occupied exactly one line.
Sample Input
5 1 2
5 2 2
Sample Output
2 4
4 3
Hint
In case two: N=5,M=2,X=2,the initial sequence One is 1,2,3,4,5.After the first operation, the sequence One

is 2,4,1,3,5. After the second operation, the sequence One is 4,3,2,1,5.So,output 4 3.

题意:n代表n个数1-n,经过m次把奇数位放在偶数位的后面的变化,输出经过m次变换后前X位。

思路:由于m比较大我们需要求出经过k次变化又变为原数列的周期T,然后由于X比较小所以我们更新的时候只需更新前X个就行了。

代码:

#include <iostream>
#include<stdio.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<vector>
#include<deque>
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int a[1000001],n;
int find_T(int x)//求周期T
{
    int pos=1;
    int k=0;
    while(1)
    {
        k++;
        if(x%2==1)//如果是奇数的话前面有偶数x/2个,奇数n+1/2个
        {
            x=(x+n+1)/2;
        }
        else
            x=x/2;//偶数的话前面只有x/2个数
        if(x==1)break;
    }
    return k;
}
int main()
{
    int m,k;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
      int T=find_T(1);
      m%=T;
      for(int i=1;i<=n;i++)
      {
          a[i]=i;
      }
      for(int i=1;i<=k;i++)
      {
          if(i!=1)
            printf(" ");
          for(int j=1;j<=m;j++)
          {
              if(a[i]*2<=n)//放偶数
              {
                  a[i]=2*a[i];
              }
              else
              {
                  a[i]=(a[i]-n/2)*2-1;//放奇数
              }
          }
          printf("%d",a[i]);
      }
      printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值