NEW RDSP MODE I (快速幂)

题目:

问题 : NEW RDSP MODE I

 

题目描述

Little A has became fascinated with the game Dota recently, but he is not a good player. In all the modes, the rdsp Mode is popular on online, in this mode, little A always loses games if he gets strange heroes, because, the heroes are distributed randomly.

Little A wants to win the game, so he cracks the code of the rdsp mode with his talent on programming. The following description is about the rdsp mode:

There are N heroes in the game, and they all have a unique number between 1 and N. At the beginning of game, all heroes will be sorted by the number in ascending order. So, all heroes form a sequence One.

These heroes will be operated by the following stages M times:

1.Get out the heroes in odd position of sequence One to form a new sequence Two;

2.Let the remaining heroes in even position to form a new sequence Three;

3.Add the sequence Two to the back of sequence Three to form a new sequence One.

After M times' operation, the X heroes in the front of new sequence One will be chosen to be Little A's heroes. The problem for you is to tell little A the numbers of his heroes.

输入

There are several test cases.

Each case contains three integers N (1<=N<1,000,000), M (1<=M<100,000,000), X(1<=X<=20).

Proceed to the end of file.

输出

For each test case, output X integers indicate the number of heroes. There is a space between two numbers. The output of one test case occupied exactly one line.

样例输入

5 1 2
5 2 2

样例输出

2 4
4 3

提示

 

In case two: N=5,M=2,X=2,the initial sequence One is 1,2,3,4,5.After the first operation, the sequence One is 2,4,1,3,5. After the second operation, the sequence One is 4,3,2,1,5.So,output 4 3.

 

 

 

题目描述:

可以发现,无论是奇数还是偶数,都是 X=2*X 之后对N取模,那么经过M次变换可以看成2的M次幂,这里写一个快速幂就行了。

还可以找出循环节t,然后t%m求余,在计算剩下的次数就可以了。

这里用的是快速幂写的。

 

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
long long m,n;
long long p(long long x,long long y,long long z)
{
    long long t = 1;
    while(y){
        if(y&1) t = (t*x)%z;
        x = (x*x)%z;
        y>>=1;
    }
    return t;
}
int main()
{   
    int i,j,k,l;
    while(scanf("%lld%lld%d",&m,&n,&k)!=EOF){
        if(m%2==0) m++;
//      n %=m;
        long long an = p(2,n,m);
        long long ans = an;
        printf("%lld",ans);
        for(i = 2;i <= k;i++){
            ans+=an;
            ans%=m;
            printf(" %lld",ans);
        }
        printf("\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值