UVA 10891 Game of Sum

题目

This is a two player game. Initially there are n integer numbers in an array and players A and B get
chance to take them alternatively. Each player can take one or more numbers from the left or right end
of the array but cannot take from both ends at a time. He can take as many consecutive numbers as
he wants during his time. The game ends when all numbers are taken from the array by the players.
The point of each player is calculated by the summation of the numbers, which he has taken. Each
player tries to achieve more points from other. If both players play optimally and player A starts the
game then how much more point can player A get than player B?
Input
The input consists of a number of cases. Each case starts with a line specifying the integer n (0 <
n ≤ 100), the number of elements in the array. After that, n numbers are given for the game. Input is
terminated by a line where n = 0.
Output
For each test case, print a number, which represents the maximum difference that the first player
obtained after playing this game optimally.
Sample Input
4
4 -10 -20 7
4
1 2 3 4
0
Sample Output
7
10

大意

给出n个数,两个人轮流取最左端点任意个数或最右端点任意个数,要求先手取到的数尽可能大。

解法

设dp[0][i][j]表示先手取从i到j这段的最大值,dp[1][i][j]表示后手取从i到j这段的最大值,sum[i]表示前i个数的和,则
dp[0][i][j]=max(dp[0][i][j],dp[1][i][k]+sum[j]-sum[k]);
dp[0][i][j]=max(dp[0][i][j],dp[1][k][j]+sum[k-1]-sum[i-1]);
dp[1][i][j]=sum[j]-sum[i-1]-dp[0][i][j];
答案就是2*dp[0][1][n]-sum[n]。

代码

#include<cstdio>
#define INF 1000000000
int dp[2][105][105],a[105],sum[105];
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n)&&n)
	{
		sum[0]=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum[i]=sum[i-1]+a[i];
		}
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				dp[0][i][j]=-INF;
				dp[1][i][j]=-INF;
			}
		for(i=1;i<=n;i++)
		{
			dp[0][i][i]=a[i];
			dp[1][i][i]=0;
		}
		for(i=2;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				int l=j,r=i+j-1;
				if(r>n)
					break;
				dp[0][l][r]=max(dp[0][l][r],sum[r]-sum[l-1]);
				for(k=l;k<r;k++)
				{
					dp[0][l][r]=max(dp[0][l][r],dp[1][l][k]+sum[r]-sum[k]);
				}
				for(k=l+1;k<=r;k++)
				{
					dp[0][l][r]=max(dp[0][l][r],dp[1][k][r]+sum[k-1]-sum[l-1]);
				}
				dp[1][l][r]=sum[r]-sum[l-1]-dp[0][l][r];
			}
		printf("%d\n",2*dp[0][1][n]-sum[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值