(PAT1030)迪杰斯特拉算法求单源最短路(进阶版) 路径+距离+花费

1030 Travel Plan (30 分)
A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output:
0 2 3 3 40
#include<bits/stdc++.h>
using namespace std;

//迪杰斯特拉算法求单源最短路(进阶版  路径+距离+花费) 
const int MAXV =505;
const int INF=0x3fffffff;
int n,m,s,e,G[MAXV][MAXV],C[MAXV][MAXV];//G记录两点间距离,C记录两点间花费 
int d[MAXV],mincost=INF; 
bool vis[MAXV]={false};
vector<int> pre[MAXV],temppath,path;


void Dijkstra(int s){
	fill(d,d+MAXV,INF);
	d[s]=0;
	for(int i=0;i<n;i++){//循环n次 
		int u=-1,min=INF;
		for(int j=0;j<n;j++){
			if(vis[j]==false&&d[j]<min){
				u=j;
				min=d[j];
			}
		}
		if(u==-1) return;
		vis[u]=true;
		for(int v=0;v<n;v++){
			if(vis[v]==false&&G[u][v]!=INF){
				if(d[u]+G[u][v]<d[v]){
					d[v]=d[u]+G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if(d[u]+G[u][v]==d[v]){
					pre[v].push_back(u);
				}
			}
		}
	}
}

void DFS(int v){
	if(v==s){//递归边界 到达叶节点 
		temppath.push_back(v);
		int tempcost=0;
		for(int i=temppath.size()-1;i>0;i--){
			int id=temppath[i],idnext=temppath[i-1];
			tempcost+=C[id][idnext];
		}
		if(tempcost<mincost){
			mincost=tempcost;
			path=temppath;
		}
		temppath.pop_back();
		return;
	}
	temppath.push_back(v);//将当前节点加入路径中 
	for(int i=0;i<pre[v].size();i++){//找当前节点的前驱 
		DFS(pre[v][i]);
	}
	temppath.pop_back();//遍历完当前节点的所有前驱,删除该节点 
}


int main(){
	cin>>n>>m>>s>>e;
	fill(G[0],G[0]+MAXV*MAXV,INF);
	fill(C[0],C[0]+MAXV*MAXV,INF);
	int u,v;
	for(int i=0;i<m;i++){
		cin>>u>>v;
		cin>>G[u][v]>>C[u][v];
		G[v][u]=G[u][v];
		C[v][u]=C[u][v];
	}
	Dijkstra(s);
	DFS(e);
	for(int i=path.size()-1;i>=0;i--){
		printf("%d ",path[i]);
	}
	cout<<d[e]<<" "<<mincost<<endl;
	return 0;
} 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值