1030. Travel Plan (30)
A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:
City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.
Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input4 5 0 3 0 1 1 20 1 3 2 30 0 3 4 10 0 2 2 20 2 3 1 20Sample Output
0 2 3 3 40
#include<stdio.h>
#include<iostream>
#include<vector>
using namespace std;
typedef struct{
int v;
int weight;
int cost;
}node;
vector <node>g[510];
int n, m, d;
int dis[510], parent[510], cos[510];
void init();
void read();
void dijkstra(int v);
void path(int v);
int main(){
int s;
scanf("%d %d %d %d", &n, &m, &s, &d);
init();
read();
dijkstra(s);
path(d);
printf("%d %d\n", dis[d], cos[d]);
return 0;
}
void path(int v){//递归打印始点到终点的路径
if(v == -1)
return ;
path(parent[v]);
printf("%d ", v);
}
void dijkstra(int v){
int i;
int cur, weight, cost;
int dist, intree[510];
for(i = 0; i < n; i++){
dis[i] = 65535;
intree[i] = 0;
parent[i] = -1;
cos[i] = 65535;
}
dis[v] = 0;
cos[v] = 0;
while(intree[v] == 0){
intree[v] = 1;
for(i = 0; i < g[v].size(); i++){
cur = g[v][i].v;
weight = g[v][i].weight;
cost = g[v][i].cost;
if(dis[cur] > dis[v] + weight || (dis[cur] == dis[v] + weight &&
cos[cur] > cos[v] + cost)){//当有多个最短路时,走花费小的一条
parent[cur] = v;
dis[cur] = dis[v] + weight;
cos[cur] = cos[v] + cost;
}
}
dist = 65535;
for(i = 0; i < n; i++){
if(intree[i] == 0 && dist > dis[i]){
dist = dis[i];
v = i;
}
}
}
}
void read(){
int i, j, k, w, c;
node e;
for(i = 0; i < m; i++){
scanf("%d %d %d %d", &j, &k, &w, &c);
e.v = k;
e.weight = w;
e.cost = c;
g[j].push_back(e);
e.v = j;
g[k].push_back(e);
}
}
void init(){
int i;
for(i = 0; i < n; i++){
g[i].clear();
}
}