pat1030

1030. Travel Plan (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40
本题是dijkstra算法的应用,但是多了个条件,当有多于一条路是最短路时,走花费小的那一条,而且题目保证当两条路等长时,花费肯定有一个更小。
dis数组保存从始点到其他所有节点的最短路径长度,只需要在更新dis数组的时候多一个条件:当最短路相等时,走花费小的一条。
打印从起点到终点的过程路径,用了一个递归,类似后序遍历。

#include<stdio.h>
#include<iostream>
#include<vector>

using namespace std;

typedef struct{
	int v;
	int weight;
	int cost;
}node;

vector <node>g[510];
int n, m, d;
int dis[510], parent[510], cos[510];

void init();
void read();
void dijkstra(int v);
void path(int v);
int main(){
	int s;
	scanf("%d %d %d %d", &n, &m, &s, &d);
	init();
	read();
	dijkstra(s);

	path(d);
	printf("%d %d\n", dis[d], cos[d]);
	return 0;
}

void path(int v){//递归打印始点到终点的路径
	if(v == -1)
		return ;
	path(parent[v]);
	printf("%d ", v);
}

void dijkstra(int v){
	int i;
	int cur, weight, cost;
    int dist, intree[510];
	
	for(i = 0; i < n; i++){
		dis[i] = 65535;
		intree[i] = 0;
		parent[i] = -1;
		cos[i] = 65535;
	}
	dis[v] = 0;
	cos[v] = 0;

	while(intree[v] == 0){
		intree[v] = 1;
		for(i = 0; i < g[v].size(); i++){
			cur = g[v][i].v;
			weight = g[v][i].weight;
			cost = g[v][i].cost;
			if(dis[cur] > dis[v] + weight || (dis[cur] == dis[v] + weight &&
 cos[cur] > cos[v] + cost)){//当有多个最短路时,走花费小的一条
				parent[cur] = v;
				dis[cur] = dis[v] + weight;
				cos[cur] = cos[v] + cost;
			}
		}

		dist = 65535;
		for(i = 0; i < n; i++){
			if(intree[i] == 0 && dist > dis[i]){
				dist = dis[i];
				v = i;
			}
		}
	}
}

void read(){
	int i, j, k, w, c;
	node e;
	for(i = 0; i < m; i++){
		scanf("%d %d %d %d", &j, &k, &w, &c);
		e.v = k;
		e.weight = w;
		e.cost = c;
		g[j].push_back(e);
		e.v = j;
		g[k].push_back(e);
	}
}

void init(){
	int i;
	for(i = 0; i < n; i++){
		g[i].clear();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值