Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

思路分析:

需要实现一个完全二叉搜索树,显然完全二叉搜索树可以通过数组来实现,所以我们将所有输入元素存入数组。

anlist=new int[N+1];
    for(int i=1;i<=N;i++)
    {
        cin>>arrylist[i];
    }

在这里我们使用插入法来建立二叉搜索树,先将原数组按从小到大排序,按照二叉树的结构,连续相邻的三个数(从小到大),应该是 左孩子 —根节点— 右孩子 所以插入数组的位置就应该是 2*i—i—i*2+1。

    inser(root*2);                      //递归左子树
    anlist[root]=arrylist[Count++];
    inser(root*2+1);                    //递归右子树

最后递归执行即可得到结果

完整代码:

#include<iostream>
#include<algorithm>
using namespace std;
int* arrylist=NULL;
int* anlist=NULL;
int Count=1;                            //记录插到第几个元素了
int N;
void inser(int root)
{
    if(root>N)
    {
        return;
    }
    inser(root*2);                      //递归左子树
    anlist[root]=arrylist[Count++];
    inser(root*2+1);                    //递归右子树
    return;
}
int main()
{
    cin>>N;
    arrylist=new int[N+1];
    anlist=new int[N+1];
    for(int i=1;i<=N;i++)
    {
        cin>>arrylist[i];
    }
    sort(arrylist+1,arrylist+N+1);
    inser(1);
    for(int i=1;i<N;i++)
    {
        cout<<anlist[i]<<" ";
    }
    cout<<anlist[N];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值