1064. Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
 
#include <iostream>
#include <vector>
#include "stdio.h"
#include <algorithm>

using namespace std;

vector<int> tree;
vector<int> nodes;
int N;
void buildTree(int root)
{
	static int index = 1;
	if(root >N) return;
	buildTree(root *2);
	tree[root] = nodes[index++];
	buildTree(root*2 +1);
}
int main()
{
	cin >> N;
	nodes.resize(N+1);
	tree.resize(N+1);
	for (int i =1;i<=N;i++)
	{
		scanf("%d",&nodes[i]);
	}
	sort(nodes.begin(),nodes.end());
	buildTree(1);
	printf("%d",tree[1]);
	printf(" ");
	for (int i=2;i<N;i++)
	{	
		printf("%d",tree[i]);
		printf(" ");
	}
	printf("%d",tree[N]);
	cout<<endl;
	return 0;
}


 
没有AC,有一个测试点错误。


/************************************************************************/
/* 完全二叉树的结点i如果从1开始编号,那么左儿子为2*i,右儿子为2*i+1;
而二叉搜索树的中序遍历为升序,因此只需要对输入序列按照升序排序,
然后对完全二叉树进行中序遍历,填入相应的元素即可。
/************************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值