杭电 6213 (map) 之 Chinese Zodiac

Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon
 

Sample Output
  
  
8 4

12

题意:一个妹子和她年轻的丈夫年龄都不知道,只知道两个人的生肖,求他们年龄之差的最小值,注意妹子的年纪比她丈夫大就行了

AC代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;

map<string,int> mp;

int main()
{
    mp["rat"]=1;mp["ox"]=2;mp["tiger"]=3;mp["rabbit"]=4;mp["dragon"]=5;mp["snake"]=6;
    mp["horse"]=7;mp["sheep"]=8;mp["monkey"]=9;mp["rooster"]=10;mp["dog"]=11;mp["pig"]=12;
    int n;
    string str1,str2;
    cin>>n;
    while(n--)
    {
        cin>>str1>>str2;
        int ans=abs(12+mp[str2]-mp[str1]);
        int ans1=abs(12+mp[str2]-mp[str1]);
        ans=min(ans,ans1);
        if(ans==0) ans=12;
        if(ans>12) ans-=12;
        cout<<ans<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值