杭电6216 (打表+二分)之 A Cubic number and A Cubic Number


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO

NO

题意:给你一个素数,判断它是不是两个立方的差, 素数只能被1和它本身整除, 因为 该素数 = a^3-b^3=(a-b)*(a^2+a*b+b^2) ,因为a,b为正整数,所以a^2+a*b+b^2>1,a-b必定为1,该素数等于相邻两个数的立方差 现在 打表+二分 即可

AC代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 2000000+10;
typedef long long llint;

llint a[maxn];

llint lifang(llint x)
{
    return x*x*x;
}

int main()
{
    int t;
    llint n;
    for(int i=1;i<maxn;i++)
    {
        a[i]=lifang(i+1)-lifang(i);
    }
    cin>>t;
    while(t--)
    {
        cin>>n;
        if(binary_search(a,a+maxn,n))//二分
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值