POJ 1328 Radar Installation (贪心)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 55428 Accepted: 12481

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题意:

在以X轴为海岸线的边界上建设雷达基站,求能覆盖所有小岛的最小雷达站个数。给出小岛个数n,雷达监控范围d,以及每个小岛的横纵坐标;

思路:

花了我好长时间才算是看懂这道题。。。现在来稍微整理一下~贪心没错,究竟应该怎么贪?看到一篇博文上写的好,说起贪心冥冥之中就感觉到要在极端点处取值。最开始的思路是用每个小岛来确定圆心,确定出圆心的固定坐标,但是情况太多,根本没办法实现。其实这道题对应于贪心中的区间问题(不好想啊。。。),每个小岛对应有一个雷达扫描区间(x-sqrt(d*d-y*y),x-sqrt(d*d-y*y)),将这个区间在对应在直线上,就变为了求解最少的点,使每个区间都被涵盖,即每个点都在雷达范围内;总结了一下网上的两种方法:

(我就是自己整理一下,不想听我说的可以直接点开链接,ws我即可)

方法一:将每个区间按照右端点排序,每次在最右段设置雷达,下一个小岛左端点在此雷达左边的点都可以被覆盖,若不满足则设置下一个雷达,向后遍历;

http://blog.csdn.net/petercsj/article/details/4602946

方法二:按左端点排序,在右端点处设置雷达,若下个点的左端点在此雷达点的右侧,设置新的雷达,向下遍历;若下个点的左端点和右端点均在此雷达点的左边,则不能覆盖,将雷达点位置改变为该点右端点处,此时能够同时覆盖两个点,向下遍历;

http://www.cnblogs.com/zjerly/archive/2011/10/31/2229871.html

我用的是方法一,代码如下(代码可能更好理解一点吧):

<span style="font-size:18px;">#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <algorithm>
#include <math.h>
#define MAX_N 1010
using namespace std;
pair<double,double> pii[MAX_N];
int n,d,sum,t_case;
bool OK;
double r_pos;//标记雷达点位置
int main()
{
    t_case=1;
    int x1,x2;
    while(cin>>n>>d)
    {
        OK=true;
        if(n==0&&d==0)
            return 0;
        for(int i=0;i<n;i++)
        {
            cin>>x1;
            cin>>x2;
            if(x2>d)
            {
                OK=false;
            }
            pii[i].first=x1+sqrt(d*d-x2*x2);//左端点
            pii[i].second=x1-sqrt(d*d-x2*x2);//右端点
        }
        sort(pii,pii+n);//默认按first排序
        sum=1;//初始预设一个雷达点
        r_pos=pii[0].first;//初始雷达点为第一个点的右端点
        for(int i=1;i<n;i++)
        {
            if(r_pos<pii[i].second)//不满足左端点在雷达点左侧
            {
                sum++;
                r_pos=pii[i].first;
            }
        }
        if(OK)//别忘了判断不满足的情况
            cout<<"Case "<<t_case<<": "<<sum<<endl;
        else
            cout<<"Case "<<t_case<<": "<<-1<<endl;
        t_case++;
    }
    return 0;
}</span><strong style="font-size: 18pt;">
</strong>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值