POJ 2376 Cleaning Shifts (贪心)

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11743 Accepted: 3058

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:

发现POJ老喜欢拿母牛说事。。。老农约翰想要让他家母牛轮班儿打扫卫生,一共有N头牛,把一天分成T个时间段,现在给出N头牛各自的空闲时间段,问你怎么安排能够将班排满,而且用到的母牛越少越好;

思路:

贪心,就是贪心,用pair存储每头牛的开始与结束时间,按照开始时间升序排序,每次找出在s这个时间点(或之前)开始能做的时间最长的母牛,下次就以这个能做最长时间的母牛的结束时间e+1作为下个起点,继续找最能干的母牛,逐个遍历;注意,只需要把每个时间段都做完,连接处并不需要覆盖,A cow starts work at the start time and finishes after the end time;

样例:

3 10

1 10

1 2

4 5

1

2 20

1 20

21  40

2

代码如下:

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define MAX_N 25010
pair <int,int> pii[MAX_N];
int N,T,sum;
int main()
{
    cin>>N>>T;
    int s=1;//T>=1,开始为1
    int e=0;//e开始设为0
    sum=0;
    for(int i=0;i<N;i++)
    {
        cin>>pii[i].first;
        cin>>pii[i].second;
    }
    sort(pii,pii+N);//默认以first升序排序
    int i=0;
    while(i<N)
    {
        while(s>=pii[i].first)
        {
            e=max(e,pii[i].second);//找到在s之前能做时间最长的母牛
            i++;
            if(i==N)//牛用完了就break
                break;
        }
        s=e+1;sum++;//换下一头牛
        if(e==T||pii[i].first>s)//当已经做到最后或者不能覆盖所有的时候,break
            break;
    }
    if(e<T)//没有做到头,输出-1
        cout<<-1<<endl;
    else
        cout<<sum<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值