UVA_103 Stacking boxes(DP)

Stacking Boxes 

Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box tex2html_wrap_inline40 (length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes tex2html_wrap_inline44 such that each box tex2html_wrap_inline46 nests in box tex2html_wrap_inline48 ( tex2html_wrap_inline50 .

A box D = ( tex2html_wrap_inline52 ) nests in a box E = ( tex2html_wrap_inline54 ) if there is some rearrangement of the tex2html_wrap_inline56 such that when rearranged each dimension is less than the corresponding dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

Formally, we define nesting as follows: box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 of tex2html_wrap_inline64such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., if tex2html_wrap_inline70 for all tex2html_wrap_inline72 .

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)

This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The tex2html_wrap_inline82line in the sequence ( tex2html_wrap_inline84 ) gives the measurements for the tex2html_wrap_inline82 box.

There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).

In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.

The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9

Sample Output

5
3 1 2 4 5
4
7 2 5 6


FAQ | About Virtual Judge
题解:多维立方体的嵌套。嵌套条件:内层立方体对应边长必须完全小于外层立方体对应边长。寻找最大的嵌套层数,并输出嵌套序列。将问题抽象就会发现这其实还是一道DP的LIS,难点在于输出嵌套序列。为此我们需要在每个立方体层内边长排序的基础上再按照每个立方体最小边长层间再次排序,这样我们就能保证每次嵌套序列的增长只会出现在原序列的末尾,不会出现插入的情况,这样方便了我们保存每个节点的上一级,最终实现输出。
附代码:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <cstring>
#include <limits>
#define MAX_N 12
#define MAX_K 32

using namespace std;

int m[MAX_K][MAX_N];
//node存储对应立方体信息,用于实现第二步排序
struct node{
    int first;
    int pos;
    const bool operator < (node next) const
    {
        return this->first < next.first;
    }
};
//point用于dp,保存长度和前一个节点
struct point{
    int last;
    int length;
};
int K,N;
int max_length;
point dp[MAX_K];
node n[MAX_K];
int save[MAX_K];
//判断是否符合嵌套条件
bool if_fit(int,int);
int main()
{
    while( scanf("%d%d",&K,&N) != EOF )
    {
        for( int i = 0; i < K; i++ )
        {
            dp[i].last=i;dp[i].length=1;
            for( int j = 0; j < N; j++ )
                scanf("%d",&m[i][j]);
            //第一步排序
            sort(m[i],m[i]+N);
            n[i].first=m[i][0];
            n[i].pos=i;
        }
        //第二步排序
        sort(n,n+K);
        max_length=0;
        for( int i = 0; i < K; i++ )
        {
            for( int j = 0; j < i; j++ )
            {
                if( if_fit( n[i].pos,n[j].pos ) )
                {
                    //保证你找到的是当前嵌套序列的最后一个节点
                    if( dp[n[i].pos].length < dp[n[j].pos].length+1 )
                    {
                        dp[n[i].pos].length = dp[n[j].pos].length+1;
                        dp[n[i].pos].last = n[j].pos;
                        //最开始的时候吧max_length的更新放在这里,WA,有可能进不来
                        //max_length = max( max_length,dp[n[i].pos].length );
                    }
                    max_length = max( max_length,dp[n[i].pos].length );
                }
            }
        }
        int t=0;
        for( int i = 0; i < K; i++ )
        {
            if( dp[i].length == max_length )
            {
                t=i;
                break;
            }
        }
        //倒着找回去,输出
        for( int i = 0; i < max_length; i++ )
        {
            save[i]=t+1;
            t=dp[t].last;
        }
        printf("%d\n",max_length);
        for( int i = max_length-1; i >= 0; i-- )
        {
            printf("%d",save[i]);
            if( i != 0 )
                printf(" ");
        }
        printf("\n");
    }
    return 0;
}
bool if_fit( int x,int y )
{
    for( int i = 0; i < N; i++ )
    {
        if( m[x][i] <= m[y][i] )
            return false;
    }
    return true;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值