Piggy-Bank
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13434 Accepted Submission(s): 6788
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
题意:有一个存钱罐,现在告诉我们所有类型钱币的质量和价值,让我们根据存钱罐的重量计算出最小可能的钱数。
题解:这道题是典型的完全背包问题,每种钱币可能有多个,我们可以选择放与不放。完全背包与01背包的区别就在于内层for循环的遍历方向。但是需要注意dp数组的初始化以及比较得出最小值。
再次做这道题,思路感觉并不是很清晰。想到了二维dp上面,其实二维一维倒不是关键,关键在于这道题不是可达的问题,而是最优的问题。dp数组应该是一个逐渐减小优化的过程,所以只需要更新最优状态就可以。动态规划的题目递推方程是关键,决定了整道题的结构,所以一定要先写好了再去敲代码。
附代码:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <cstring>
#include <limits.h>
#define MAX_N 510
#define MAX_M 10020
#define INF 0xfffffff
using namespace std;
int T,E,F,N;
//储存重量为j时的最小钱币价值
int dp[MAX_M];
int p[MAX_N];
int w[MAX_N];
int main()
{
cin>>T;
while( T-- )
{
scanf("%d%d",&E,&F);
scanf("%d",&N);
//dp数组的初始化,因为需要求最小值,所以初始化为一个较大的数
for( int i = 0; i <= F-E; i++ )
dp[i]=INF;
dp[0]=0;//重量为0时价值为0
for( int i = 0; i < N; i++ )
scanf("%d%d",&p[i],&w[i]);
for( int i = 0; i < N; i++ )
{
//从低向高++
for( int j = w[i]; j <= F-E; j++ )
dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
}
if( dp[F-E] < INF )
printf("The minimum amount of money in the piggy-bank is %d.",dp[F-E]);
else
printf("This is impossible.");
printf("\n");
}
return 0;
}