Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题目在这里~
题目描述:
给出一个数字,可执行三种操作,+1,-1,×2.问最少经过多少步能到达目标点。
题解:
因为思路很简单,就是一道BFS,手写DFS错了很久,关键在于不好记忆化。放到队列里面标记很好的解决了这个问题。已经在队列里面的点不需要继续放入,防止了重复计算。
代码:
#include <iostream>
#include <math.h>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
struct node{
int val;
int cos;
};
int num;
int N,K;
queue<node> q;
int show[100000+2];
void DFS(int x,int time);
int main()
{
while( cin>>N>>K )
{
memset(show,0,sizeof(show));
show[N]=1;
num = -1;
node a,tem;
show[N]=1;
a.val=N;
a.cos=0;
q.push(a);
while( !q.empty() )
{
node t;
tem = q.front();
q.pop();
if( tem.val == K )
{
num=tem.cos;
break;
}
if( tem.val + 1 <= 100000 && show[tem.val+1]!=1 )
{
t.val=tem.val+1;
t.cos=tem.cos+1;
q.push(t);
show[tem.val+1]=1;
}
if( tem.val-1 >= 0 && show[tem.val-1]!=1)
{
t.val=tem.val-1;
t.cos=tem.cos+1;
q.push(t);
show[tem.val-1]=1;
}
if( tem.val*2 <= 100000 && show[tem.val*2]!=1 )
{
t.val=tem.val*2;
t.cos=tem.cos+1;
q.push(t);
show[tem.val*2]=1;
}
}
cout<<num<<endl;
}
return 0;
}