POJ 3187 Backward Digit Sums (DFS 全排列)

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4531 Accepted: 2604

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source


思路:

简单题,全排列遍历,本以为会超时,但是竟然水过了,求和的时候应该可以有更好的算法;比较的时候要注意,刚开始想复杂了,其实就是简单的按位比较,用int型数组存储很方便。

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const long long INF=10000000000;//要大一些
int perm[15];
int perm2[15];
int sum,N;
int num[15]={10,9,8,7,6,5,4,3,2,1};//初始化为最大
void permutation();
int main()
{
    while(cin>>N>>sum)
    {
        permutation();
        for(int i=0;i<N-1;i++)
            cout<<num[i]<<' ';
        cout<<num[N-1]<<endl;
    }
    return 0;
}
void permutation()
{
    for(int i=0;i<N;i++)
        perm[i]=i+1;
    do{
        for(int i=0;i<N;i++)
            perm2[i]=perm[i];
        for(int j=0;j<N-1;j++)
        {
            for(int i=0;i<N-1-j;i++)
            {
                perm2[i]=perm2[i]+perm2[i+1];
            }
        }
        if(perm2[0]==sum)
        {
            for(int i=0;i<N;i++)
            {
                if(num[i]>perm[i])
                {
                    for(int i=0;i<N;i++)
                        num[i]=perm[i];
                    break;
                }
                else if(num[i]<perm[i])
                {
                    break;
                }
            }
        }
    }while(next_permutation(perm,perm+N));
    return ;
}
附上一个比较好的代码 微笑

http://blog.sina.com.cn/s/blog_6635898a0100kko3.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值