PAT:B1042 字符统计(20 分)

PAT:B1042 字符统计(20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

思路:

1.因为不区分大小写,所以遇到的大写全部按照小写进行计算。

2.用一个26的字母进行统计

3.开始遍历,得出最频率最高的小写字母,以及出现频率

代码:

C/C++:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn = 1010;
int main() {
	char str[maxn], c1;
	int a[26] = {0};
	cin.get(str, maxn);
	int len = strlen(str);
	for(int i = 0; i < len; i++) {
		c1 = str[i];
		if(c1 >= 'A' && c1 <= 'Z') {
			c1 = c1 + 32;
			a[c1-'a']++;
		} else if(c1 >= 'a' && c1 <= 'z') a[c1 - 'a']++;
	}
	int loc, max = -1;
	for(int i = 0; i < 26; i++) {
		if(max < a[i]) {
			max = a[i];
			loc = i;
		}
	}
	c1 = 'a' + loc;
	printf("%c %d", c1, max);
	
	return 0;
}

Java:

import java.util.Scanner;

/**
 * @author 余修文
 * @date 2018/9/19 10:39
 */
public class Main {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String str;
        char b;
        int[] count = new int[26];
        int maxn = -1, loc = 0;
        str = in.nextLine();
        for (int i = 0;  i < str.length(); i++) {
            b = str.charAt(i);
            if(b >= 'a' && b <= 'z') {
                count[b - 'a']++;
            } else if (b >= 'A' && b <= 'Z') {
                count[b - 'A']++;
            }
        }
        in.close();
        for (int i = 0; i < 26; i++) {
            if (count[i] > maxn) {
                maxn = count[i];
                loc = i;
            }
        }
        b = (char)('a' + loc);
        System.out.printf("%c %d\n", b, maxn);
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值