PAT:A1088 Rational Arithmetic (20 分)

PAT:A1088 Rational Arithmetic (20 分)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;

// 本题用到了分数的加减,化简,寻找公约数, 分子的输出 
int gcd(ll a, ll b) {
	if(b == 0) return a;
	else return gcd(b, a%b);
}

// 分数的构造体
struct Fraction{
	long long up, down;
}; 

// 分数的化简
Fraction reduction(Fraction r) {
	if(r.down < 0) {
		r.up = -r.up;
		r.down = -r.down;
	}
	if(r.up == 0) r.down = 1;
	else {
		ll d = gcd(abs(r.up), abs(r.down));
		r.up = r.up / d;
		r.down = r.down / d;
	} 	
	return r;
}

// 分数的加法
Fraction add(Fraction a, Fraction b) {
	a = reduction(a), b = reduction(b);
	Fraction c;
	c.down = a.down * b.down;
	c.up = a.up * b.down + a.down * b.up;
	return reduction(c);
} 

// 分数的减法
Fraction sub(Fraction a, Fraction b) {
	a = reduction(a), b = reduction(b);
	Fraction c;
	c.down = a.down * b.down;
	c.up = a.up * b.down - a.down * b.up;
	return reduction(c);
} 

// 分子的乘法
Fraction mult(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up * b.up;
	c.down = a.down * b.down;
	return reduction(c);
} 

// 分子的除法
Fraction divide(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up * b.down;
	c.down = a.down * b.up;
	return reduction(c);
} 

// 分数的输出
void printFra(Fraction r) {
	r = reduction(r);
	if(r.up * r.down < 0) {
		if(r.down == 1) printf("(%lld)", r.up);
		else if(abs(r.up) > abs(r.down)) printf("(%lld %lld/%lld)", r.up/r.down, abs(r.up)%r.down, r.down);
		else {
			printf("(%lld/%lld)", r.up, r.down);
		}
	} else {
		if(r.up == 0) printf("%lld", r.up);
		else if(r.down == 1) printf("%lld", r.up);
		else if(r.up > r.down) printf("%lld %lld/%lld", r.up/r.down, r.up%r.down, r.down);
		else {
			printf("%lld/%lld", r.up, r.down);
		}
	} 
	
} 

int main() {
	Fraction a, b;
	scanf("%lld/%lld %lld/%lld", &a.up, &a.down, &b.up, &b.down);
	char alg[4][5] = {" + ", " - ", " * ", " / "};
	for(int i = 0; i < 4; i++) {
		printFra(a);
		printf("%s", alg[i]);
		printFra(b);
		printf(" = ");
		switch(i) {
			case 0:
				printFra(add(a, b));
				break;
			case 1:
				printFra(sub(a, b));
				break;
			case 2:
				printFra(mult(a, b));
				break;
			default:
				if(b.up == 0) {
					printf("Inf");
				} else {
					printFra(divide(a, b));
				}
		}
		if(i != 3)	printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值