1088. Rational Arithmetic (20)

1088. Rational Arithmetic (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
给出两个分数,求他们的和,差,积,商(分数四则运算);
通过辗转相除gcd获得最大公约数;可以把两个分数化为最简的形式;
重点是输出的格式
如果分母为零,那么输出的是Inf;
如果值为零,那么0
如果是正数,那么化为对应K a/b  或者K 或者a/b (其中a/b为真分数形式)
如果是负数,一定要有括号,化为对应的-K a/b 或者-K 或者-a/b

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月18日 16:49答案正确201088C++ (g++ 4.7.2)1300datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确11809/9
1答案正确11805/5
2答案正确13003/3
3答案正确13003/3
#include<iostream>
#include<string>    
using namespace std;
long int gcd(long int beichushu, long int chushu)
{
  return chushu == 0 ?  beichushu: gcd(chushu, beichushu%chushu);
} 
void GaiBianXingShi(long int &a, long int &b)
{
  int G = gcd(b, a);
  a /= G;
  b /= G; 
} 
void shuchuyige(long int a, long int b)
{ 
  if (b == 0)cout << "Inf";
  else 
  {
      if (b < 0){ a = -a; b = -b; }
    bool parentheses = false;
    if (a < 0)parentheses = true;
    if (parentheses)cout << "(";
    if (a%b == 0)cout << a / b;
    else  
    {  
      if (a / b != 0)
      { 
        cout << a / b << " ";  
        if (a%b < 0)a = -a%b;
      } 
      cout << a%b<<"/"<<b;
    } 
    if (parentheses)cout << ")";
  }
}
void JiaFa(long int*a, long int *b,long int G)
{
  b[2] = b[1] * b[0] / G;
  a[2] = a[0] * b[1] / G + a[1] * b[0] / G;
  G = gcd(b[2], a[2]);
  a[2] /= G;
  b[2] /= G;
  shuchuyige(a[0], b[0]);
  cout << " + ";
  shuchuyige(a[1], b[1]);
  cout << " = ";
  shuchuyige(a[2], b[2]);
  cout << endl;
}
void JianFa(long int*a, long int *b, long int G)
{
  b[2] = b[1] * b[0] / G;
  a[2] = a[0] * b[1] / G - a[1] * b[0] / G;
  G = gcd(b[2], a[2]);
  a[2] /= G;
  b[2] /= G;
  shuchuyige(a[0], b[0]);
  cout << " - ";
  shuchuyige(a[1], b[1]);
  cout << " = ";
  shuchuyige(a[2], b[2]);
  cout << endl;
}
void ChengFa(long int*a, long int *b, long int G)
{
  b[2] = b[1] * b[0] ;
  a[2] = a[0] * a[1] ;
  G = gcd(b[2], a[2]);
  a[2] /= G;
  b[2] /= G;
  shuchuyige(a[0], b[0]);
  cout << " * ";
  shuchuyige(a[1], b[1]);
  cout << " = ";
  shuchuyige(a[2], b[2]);
  cout << endl;
}
void ChuFa(long int*a, long int *b, long int G)
{
  b[2] = b[0] * a[1];
  a[2] = b[1] * a[0];
  G = gcd(b[2], a[2]);
  a[2] /= G;
  b[2] /= G;
  shuchuyige(a[0], b[0]);
  cout << " / ";
  shuchuyige(a[1], b[1]);
  cout << " = ";
  shuchuyige(a[2], b[2]);
  cout << endl;
}
int main()
{
  long int a[3], b[3],Gmax;
  char ctemp;
  cin >> a[0]>> ctemp >> b[0]>> a[1] >> ctemp >> b[1]; 
  if (0 == b[0] || 0 == b[1])cout << "Inf" << endl;
  else
  {
    GaiBianXingShi(a[0], b[0]);
    GaiBianXingShi(a[1], b[1]); 
    Gmax = gcd(b[0], b[1]);  
    JiaFa(a, b, Gmax);
    JianFa(a, b, Gmax);
    ChengFa(a, b, Gmax);
    ChuFa(a, b, Gmax);
  }
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值