九度[1095]-2的幂次方

九度[1095]-2的幂次方

题目描述:
Every positive number can be presented by the exponential form.For example, 137 = 2^7 + 2^3 + 2^0。
Let’s present a^b by the form a(b).Then 137 is presented by 2(7)+2(3)+2(0). Since 7 = 2^2 + 2 + 2^0 and 3 = 2 + 2^0 , 137 is finally presented by 2(2(2)+2 +2(0))+2(2+2(0))+2(0).

Given a positive number n,your task is to present n with the exponential form which only contains the digits 0 and 2.

输入
For each case, the input file contains a positive integer n (n<=20000).

输出
For each case, you should output the exponential form of n an a single line.Note that,there should not be any additional white spaces in the line.

样例输入
1315

样例输出
2(2(2+2(0))+2)+2(2(2+2(0)))+2(2(2)+2(0))+2+2(0)

解题思路:
递归,难点就是怎么分解这个数字,我是真菜啊。。。。

AC代码:

#include <cstdio>
#include <cmath> 
int n;

void print(int n){
    int cnt = 0;
    while(pow(2, cnt) <= n){
        cnt++;
    }
    cnt--;
    if(cnt == 0) printf("2(0)");
    else if(cnt == 1) printf("2");
    else{
        printf("2(");
        print(cnt);
        printf(")");
    }
    n -= pow(2, cnt);
    if(n != 0) {
        printf("+");
        print(n);
    }
}
int main(){
    while(scanf("%d", &n) != EOF){
        print(n);
        printf("\n");
    }
    return 0;
}

参考链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值