PAT [A1020]-Tree Traversals

PAT [A1020]-Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output 1:
4 1 6 3 5 7 2

解题思路:
递归构造二叉树(后序中序确定一颗二叉树),并利用BFS输出层次遍历。

AC代码:

#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 50;
int N, postOrder[maxn], inOrder[maxn];
struct node{
    int v;
    node* lChild;
    node* rChild;
};

node* create(int lp, int rp, int li, int ri){
    if (lp > rp) return NULL;
    node* root = new node;
    root->v = postOrder[rp];
    int index;
    for (int i = li; i <= ri; i++){
        if (inOrder[i] == postOrder[rp]){
            index = i;
            break;
        }
    }
    root->lChild = create(lp, index - 1 - li + lp, li, index - 1);
    root->rChild = create(rp-ri+index, rp-1, index + 1, ri);
    return root;
}

void BFS(node* root){
    int cnt = 0, ans[maxn];
    queue<node*> que;
    que.push(root);
    while (!que.empty()){
        node *t = que.front();
        ans[cnt++] = t->v;
        que.pop();
        if(t->lChild != NULL) que.push(t->lChild);
        if (t->rChild != NULL) que.push(t->rChild);
    }
    for (int i = 0; i < cnt; i++){
        printf("%d", ans[i]);
        if (i < cnt - 1) printf(" ");
    }
}

int main(){
    freopen("C:\\Users\\Administrator\\Desktop\\test.txt", "r", stdin);
    while (scanf("%d", &N) != EOF){
        for (int i = 0; i < N; i++){
            scanf("%d", &postOrder[i]);
        }
        for (int i = 0; i < N; i++){
            scanf("%d", &inOrder[i]);
        }
        node* root = create(0, N-1, 0, N-1);
        BFS(root);
        printf("\n");
    }
    fclose(stdin);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值