PAT-A1020 Tree Traversals【树的遍历】【BFS】

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:

给出后序遍历和中序遍历,求输出层次遍历,不能有多余的空格

结题思路:

根据后序遍历和中序遍历构造二叉树,使用BFS进行层序遍历。

So?怎么根据后续遍历和中序遍历求出整个二叉树?

以本题为例,我们知道后序遍历就是最后输出父节点,那么后序遍历的最后一个数字一定是根节点,也就是4;

中序遍历是中间输出父节点,利用根节点是4,把中序遍历的结果分成两部分,左边部分是左子树,右部分是右子树。

计算左边节点的数量k,从后序遍历的结果中从头开始取k个节点重复上面过程。右部分同理


#include <stdio.h>
#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
const int maxnum=31;
int post[maxnum];
int in[maxnum];
int n,rt;

struct node{
	int data;
	node * lchild;
	node * rchild;
}nodes[maxnum];
node* createTree(int postl,int postr,int inl,int inr){
	if(postl>postr){
		return NULL;
	}
	int k;
	for(int i=inl;i<=inr;i++){
		if(in[i]==post[postr]){
			k=i;
			break;
		}
	}
	int numleft=k-inl;
	node * now=new node;
	now->data=post[postr];
	now->lchild=createTree(postl,postl+numleft-1,inl,inl+numleft-1);
	now->rchild=createTree(postl+numleft,postr-1,numleft+inl+1,inr);
	return now;
}
int num=0;
void bfs(node * root){
	queue<node *> q;
	q.push(root);
	while(!q.empty()){
		node * now=new node;
		now=q.front();
		printf("%d",now->data);
		num++;
		if(n!=num){
		printf(" ");
		}
		q.pop();

		if(now->lchild!=NULL)q.push(now->lchild);
		if(now->rchild!=NULL)q.push(now->rchild);
	}
}
int main(){
	int temp;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&temp);
		post[i]=temp;
	}
	for(int j=0;j<n;j++){
		scanf("%d",&temp);
		in[j]=temp;
	}
	node *root=createTree(0,n-1,0,n-1);
	bfs(root);
return 0;
}

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值