1020. 月饼 (25)

题目要求

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例

3 20
18 15 10
75 72 45

输出样例

94.50

解题思路

源码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct mooncake{
    double price;
    double count;
    double priceCount;
};

int compareMin(mooncake m1,mooncake m2) {
    return m1.price > m2.price;
}

int main() {
    int n;
    cin >> n;
    int needs;
    cin >> needs;
    mooncake *m = new mooncake[n];
    for (int i = 0;i < n;i++) {
        cin >> m[i].count;
    } 
    for (int i = 0;i < n;i++) {
        cin >> m[i].priceCount;
    }
    for (int i = 0;i < n;i++) {
        m[i].price = m[i].priceCount / m[i].count;
    }
    sort(m,m+n,compareMin);
    double result = 0.0;
    for (int i = 0; i < n; i++) {
        if (m[i].count <= needs) {  
            result = result + m[i].priceCount;  
        } else {  
            result = result + m[i].price * needs;  
            break;  
        }  
        needs = needs - m[i].count;  
    }  
    printf("%.2f",result);  
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值