L1-020. 帅到没朋友

题目要求

当芸芸众生忙着在朋友圈中发照片的时候,总有一些人因为太帅而没有朋友。本题就要求你找出那些帅到没有朋友的人。

输入格式

输入第一行给出一个正整数N(<=100),是已知朋友圈的个数;随后N行,每行首先给出一个正整数K(<=1000),为朋友圈中的人数,然后列出一个朋友圈内的所有人——为方便起见,每人对应一个ID号,为5位数字(从00000到99999),ID间以空格分隔;之后给出一个正整数M(<=10000),为待查询的人数;随后一行中列出M个待查询的ID,以空格分隔。

注意:没有朋友的人可以是根本没安装“朋友圈”,也可以是只有自己一个人在朋友圈的人。虽然有个别自恋狂会自己把自己反复加进朋友圈,但题目保证所有K超过1的朋友圈里都至少有2个不同的人。

输出格式

按输入的顺序输出那些帅到没朋友的人。ID间用1个空格分隔,行的首尾不得有多余空格。如果没有人太帅,则输出“No one is handsome”。

注意:同一个人可以被查询多次,但只输出一次。

输入样例

3
3 11111 22222 55555
2 33333 44444
4 55555 66666 99999 77777
8
55555 44444 10000 88888 22222 11111 23333 88888

输出样例

10000 88888 23333

解题思路

源码

#include <iostream>
using namespace std;

int main() {
    int num;
    cin >> num;
    int a[100001] = {0};
    int n = 0;
    int temp = 0;
    for (int i = 0;i < num;i++) {
        cin >> n;
        for (int j = 0;j < n;j++) {
            cin >> temp;
            if (n == 1) {
                continue;
            } else {
                a[temp] = 1;
            }
        }
    }
    bool state = false;
    int member;
    cin >> member;
    int singleDog = 0;
//  bool flag = false;
    for (int i = 0;i < member;i++) {
        cin >> singleDog;
//      if (!flag) {
//          flag = true;
//      } else {
//          cout << " ";
//      }
        if (a[singleDog] != 1) {
            a[singleDog] = 1;
            if (state == false) {
                if (singleDog / 10000 == 0) {
                    state = true;
                    cout << "0" <<singleDog;
                } else if (singleDog / 1000 == 0) {
                    state = true;
                    cout << "00" <<singleDog;
                } else if (singleDog / 100 == 0) {
                    state = true;
                    cout << "000" <<singleDog;
                } else if (singleDog / 10 == 0) {
                    state = true;
                    cout << "0000" <<singleDog;
                } else {
                    state = true;
                    cout << singleDog;
                }
            } else {
                if (singleDog / 10000 == 0) {
                    state = true;
                    cout << " 0" <<singleDog;
                } else if (singleDog / 1000 == 0) {
                    state = true;
                    cout << " 00" <<singleDog;
                } else if (singleDog / 100 == 0) {
                    state = true;
                    cout << " 000" <<singleDog;
                } else if (singleDog / 10 == 0) {
                    state = true;
                    cout << " 0000" <<singleDog;
                } else {
                    cout << " " << singleDog;
                }
            }
        }
    }
    if (!state) {
        cout << "No one is handsome";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值