杭电OJ题 1347 Grandpa is Famous解题报告

Grandpa is Famous

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 481    Accepted Submission(s): 168



Problem Description
The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!

The International Bridge Association (IBA) has maintained, for several years, a weekly rank? ing of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.

Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.
 

Input
The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:

1. in each test case there is exactly one best player and at least one second best player,
2. each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.
 

Output
For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.
 

Sample Input
  
  
4 5 20 33 25 32 99 32 86 99 25 10 20 99 10 33 86 19 33 74 99 32 3 6 2 34 67 36 79 93 100 38 21 76 91 85 32 23 85 31 88 1 0 0
 

Sample Output
  
  
32 33 1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
 


——————————————————————————————————————————————————————

简单的排序问题,先求出每个选手出现在每周排行榜上的次数,然后对出现的次数排序,找出排在第二大的次数的所有人


代码:

/****************************
 *Name:Grandpa is Famous.c
 *Tags:ACM water
 ****************************/

#include <stdio.h>

int main()
{
      int rank[10001], r;
      int m, n, i, j, max_1, max_2;
      while(scanf("%d%d", &n, &m) != EOF && m && n) {
	    for(i = 1; i < 10001; i++) {
		  rank[i] = 0;
	    }
	    for(i = 0; i < n; i++) {
		  for(j = 0; j < m; j++) {
			scanf("%d", &r);
			rank[r]++;
		  }
	    }
	    /* for(i = 0; i < 10000; i++) { */
	    /* 	  printf("%d ", rank[i]); */
	    /* } */
	    /* printf("\n"); */
	    max_1 = 0;
	    max_2 = 0;
	    for(i = 1; i < 10001; i++) {
		  if(max_1 < rank[i]) {
			max_1 = rank[i];
		  }
	    }/* find the max */
	    for(i = 1; i < 10001; i++) {
		  if(max_2 < rank[i]) {
			if(max_1 > rank[i]) {
			      max_2 = rank[i];
			}
		  }
	    }/* find the second max */
	    for(i = 1; i < 10001; i++) {
		  if(rank[i] == max_2) {
			printf("%d", i);
			break;
		  }
	    }
	    for(i = i+1; i < 10001; i++) {
		  if(rank[i] == max_2) {
			printf(" %d", i);
		  }
	    }
	    printf("\n");
      }
      return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
杭电oj是杭州电子科技大学开发的一个在线评测系统,主要用于计算机考研的教育辅助工具。对于计算机考研的学生来说,杭电oj提供了一个良好的平台,可以进行编程练习和算法训练,帮助学生提升编程能力和算法水平。 首先,杭电oj上有大量的目库,涵盖了计算机考研的各个方面,比如数据结构、算法设计、数据库等,学生可以根据自己的需要选择相应的目进行练习。目难度分级明确,从简单到困难,适合不同水平的学生进行练习。通过解题训练,学生可以熟悉各类算法思想和程序设计方法,提高解题能力。 其次,杭电oj提供了在线评测系统,可以帮助学生及时了解自己的编程能力和代码水平。在解答目后,杭电oj会自动评判答案的正确性和效率,以及输出格式是否正确。学生可以根据评测结果对自己的代码进行优化和改进,提高编程的正确性和效率。 此外,杭电oj还提供了讨论区功能,学生可以与其他考研学生进行交流和讨论。在讨论区里,学生可以提问、回答问,分享解题思路和经验,相互学习和进步。通过互助学习,学生可以更好地理解和掌握各类算法和编程知识,提高解题的能力和效率。 总的来说,杭电oj对于计算机考研的学生是一个非常有用的教育辅助工具,它提供了库、评测系统和讨论区,能够帮助学生提升编程能力和算法水平,提高解题能力和效率。对于计算机考研的学生来说,积极利用杭电oj进行练习和学习,能够有效地提高自己的竞争力和通过考研的概率。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值