杭电OJ题1719 Friend 解题报告

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1320    Accepted Submission(s): 643



Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
  
  
3 13121 12131
 

Sample Output
  
  
YES! YES! NO!
 
————————————————————————————————————
通过公式可以推出friend number = (x^2)*(y^3)-1,即如果一个数可以被2整除,当一直除2直到不能整除时如果余下的数可以被3整除,最后可以一直被3整除直至1,那这个数为friend number

/****************************
 *Name:Friend.c
 *Tags:ACM water
 *Note:通过公式可以推出friend number = (x^2)*(y^3)-1,即如果一个数可以被2整除,当一直除2直到不能整除时如果余下的数可以被3整除,最后可以一直被3整除直至1,那这个数为friend number
 ****************************/

#include <stdio.h>

int main()
{
      int a;
      int i, j, f;
      while(scanf("%d", &a) != EOF) {
	    if(a == 0) {
		  printf("NO!\n");
		  continue;
	    }
	    a += 1;
	    while(a % 2 == 0) {
		  a /= 2;
	    }
	    while(a % 3 == 0) {
		  a /= 3;
	    }
	    if(a == 1) {
		  printf("YES!\n");
	    } else {
		  printf("NO!\n");
	    }
      }
      return 0;
}		  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值