ZOJ-1236 Eat or Not to Eat?

Eat or Not to Eat?


Time Limit: 10 Seconds      MemoryLimit: 32768 KB


A young farmer hasN cows, but they produced really really a very very small amount of milk. Johncannot live on the milk they made, so he's planning to eat some of the 'worst'cows to get rid of hunger. Each day, John chooses the cow that produces theLEAST amount of milk on that day and eat them. If there are more than one cowwith minimal milk, John will be puzzled and will not eat any of them (Yeah!That's GREAT!!).

The i-th cow has acycle of production Ti. That means, if it produces L unit milk on one day, itwill also produce L unit after Ti days -- If it will not be eaten during theseday :-). Though John is not a clever man, he doubts whether the cows will beeventually eaten up, so he asks for your help. Don't forget that he will offeryou some nice beef for that!


Input

The first line ofthe input contains a single integer T, indicating the number of test cases.(1<=T<=500) Each test case begins with an integer N(1<=N<=1000),the number of cows. In the following N lines, each line contains an integerTi(1<=Ti<=10), indicating the cycle of the i-th cow, then Ti integersMj(0<=Mj<=250) follow, indicating the amount of milk it can produce onthe j-th day.


Output

For each test casein the input, print a single line containing two integers C, D, indicating thenumber of cows that will NOT be eaten, and the number of days passed when thelast cow is eaten. If no cow is eaten, the second number should be 0.


Sample Input

1
4
4 7 1 2 9
1 2
2 7 1
1 2


Sample Output

2 6


#include <stdio.h>

struct node {
      int T;
      int m[11];
      int kill;
};
int test(struct node *, int, int, int);
int main()
{
      int T, n, i, j, f;
      int min, count, temp, total, day, circul;
      struct node cow[1001];
      scanf("%d", &T);
      while(T--) {
	    scanf("%d", &n);
	    for(i = 0; i < n; i++) {
		  scanf("%d", &cow[i].T);
		  cow[i].kill = 0;
		  for(j = 0; j < cow[i].T; j++) {
			scanf("%d", &cow[i].m[j]);
		  }
	    }
	    f = 1;
	    i = 0;
	    total = n;
	    circul = 0;
	    while(f) {
		  min = 1000;
		  count = 0;
		  for(j = 0; j < n; j++) {
			if(!cow[j].kill) {
			      if(cow[j].m[i % cow[j].T] < min) {
				    min = cow[j].m[i % cow[j].T];
				    temp = j;
				    count = 1;
			      }
			      else if(cow[j].m[i % cow[j].T] == min) {
				    count++;
			      }
			}
		  }
		  if(count == 1) {
			cow[temp].kill = 1;
			total--;
			circul = 0;
		  } else {
			circul++;
		  }
		  if(circul >= 500) {
			f = 0;
			break;
		  }
		  i++;
	    }
	    if(total == n) {
		  day = 0;
	    } else {
		  day = i + 1 - circul;
	    }
	    printf("%d %d\n", total, day);
      }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值