PAT1119

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4
#include<iostream>
#define INF 0x3f3f3f3f
using namespace std;
int n;
vector<int> in, pre, post;
bool uniquer = true;

void getin(int prel, int prer, int postl, int postr){
	if(postl == postr) {//若遍历左右相等,则说明此子树为叶节点
		in.push_back(post[postr]);//叶节点直接插入中序遍历中
        return;
	}
    if (pre[prel] == post[postr]) {//前序的开始的第一个应该是后序的最后一个是相等的,这个结点就是根结点
        int i = prel + 1;
        while (pre[i]!=post[postr-1]) i++;
        if (i - prel > 1)//i-prel=1时代表只有一个子树
            getin(prel + 1, i - 1, postl, postl + (i - prel - 1) - 1);
        else
            uniquer = false;
        in.push_back(post[postr]);
        getin(i, prer, postl + (i - prel - 1), postr - 1);
    }
}

int main() {
    cin>>n;
    pre.resize(n), post.resize(n);
    for(int i=0;i<n;i++)
    	cin>>pre[i];
	for(int i=0;i<n;i++)
    	cin>>post[i];
	getin(0, n-1, 0, n-1);
	printf("%s\n%d", uniquer == true ? "Yes" : "No", in[0]);
	for (int i = 1; i < in.size(); i++)
		printf(" %d", in[i]);
	puts("");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值