PAT甲级——1119 Pre- and Post-order Traversals(先序+后序序列,建立二叉树)

1119 Pre- and Post-order Traversals (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

 题目大意:给定先序和后序序列,输出二叉树的中序遍历序列。若二叉树不唯一则输出任意解。

思路:下一个节点与当前节点在后序数组中紧挨着就说明二叉树不唯一,因为无法判断它是当前节点的左孩子还是右孩子。递归地建立二叉树的时候需要传递四个变量,preLeft、preRight、postLeft、postRight,也就是子树的范围、左右边界在先序和后序数组中的下标。

注意:输出二叉树后要换行!!!不然会格式错误。

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
typedef struct node *BT;
struct node {
	int key;
	BT left = NULL, right = NULL;
};
int N;
bool flag = false, unique = true;
unordered_map <int, int> postMp;
vector <int> pre, post;
BT buildTree(int preLeft, int preRight, int postLeft, int postRight);
void inorder(BT tree);//中序遍历
int main()
{
	int i;
	scanf("%d", &N);
	pre.resize(N);
	post.resize(N);
	for (i = 0; i < N; i++) {
		scanf("%d", &pre[i]);
	}
	for (i = 0; i < N; i++) {
		scanf("%d", &post[i]);
		postMp[post[i]] = i;
	}
	BT tree = NULL;
	tree = buildTree(0, N - 1, 0, N - 1);
	printf(unique ? "Yes\n" : "No\n");
	inorder(tree);
    printf("\n");//结果后面要换行!!!否则就是格式错误,我还能说啥?
}
BT buildTree(int preLeft, int preRight, int postLeft, int postRight) {
	BT tree = new node();
	tree->key = pre[preLeft];
	if (preLeft == preRight) {
		return tree;
	}
	int next = preLeft + 1;
	if (postMp[pre[preLeft]] - postMp[pre[next]] == 1) {
		unique = false;
		tree->left = buildTree(next, preRight, postLeft, postMp[pre[next]]);
	}
	else {
		int leftNum = postMp[pre[next]] - postLeft;
		tree->left = buildTree(next, next + leftNum, postLeft, postMp[pre[next]]);
		next = next + leftNum + 1;
		tree->right = buildTree(next, preRight, postMp[pre[preLeft + 1]] + 1, postMp[pre[next]]);
	}
	return tree;
}
void inorder(BT tree) {
	if (tree) {
		inorder(tree->left);
		if (flag)
			printf(" ");
		flag = true;
		printf("%d", tree->key);
		inorder(tree->right);
	}
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值