Number Triangles
Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.
PROGRAM NAME: numtri
INPUT FORMAT
The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.SAMPLE INPUT (file numtri.in)
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
OUTPUT FORMAT
A single line containing the largest sum using the traversal specified.SAMPLE OUTPUT (file numtri.out)
30
思路:dp,从下往上bfs即可
/*
ID: youqihe1
PROG: numtri
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <string>
#include<algorithm>
using namespace std;
int A[1001][1001];
int main()
{
FILE *fin = fopen ("numtri.in", "r");
FILE *fout = fopen ("numtri.out", "w");
int N;
fscanf(fin,"%d",&N);
int i,j,k;
for(i=0;i<N;i++)
for(j=0;j<=i;j++)
fscanf(fin,"%d",&A[i][j]);
for(i=N-2;i>=0;i--)
{
for(j=0;j<=i;j++)
A[i][j]+=max(A[i+1][j],A[i+1][j+1]);
}
fprintf(fout,"%d\n",A[0][0]);
return 0;
}