Persistent Numbers(大数+发现java注意点!!!)

79 篇文章 0 订阅
73 篇文章 0 订阅

Link:点击打开链接

Problem:

Persistent Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3029 Accepted: 1470

Description

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6, 1973, pp. 97-98., 1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example: 
679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is, the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is known that there are numbers with the persistence of 11. It is not known whether there are numbers with the persistence of 12 but it is known that if they exists then the smallest of them would have more than 3000 digits. 
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?

Input

For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.

Output

For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.

Sample Input

0
1
4
7
18
49
51
768
-1

Sample Output

10
11
14
17
29
77
There is no such number.
2688

Source


错误代码:

import java.util.*;

import java.io.*;
import java.math.*;
import java.text.*;


public class Main{
public static void main(String[] args)
{
BigInteger x;
int i;
        String s;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(-1))==0)
break;
if(x.compareTo(BigInteger.valueOf(10))<0)
{
System.out.println("1"+x);
}
else
{
                                s="";
for(i=9;i>=2;i--)
{
while(x.mod(BigInteger.valueOf(i))==BigInteger.valueOf(0))//这样写poj是wa!!!
{
                                                s=i+s;
x=x.divide(BigInteger.valueOf(i));
}
}
if(x.compareTo(BigInteger.ONE)!=0)
{
System.out.println("There is no such number.");
}
else
{
System.out.println(s);
}
}
}
}

}


发现后改正AC代码:

import java.util.*;
import java.io.*;
import java.math.*;
import java.text.*;


public class Main{
public static void main(String[] args)
{
BigInteger x;
int i;
        String s;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(-1))==0)
break;
if(x.compareTo(BigInteger.valueOf(10))<0)
{
System.out.println("1"+x);
}
else
{
                                s="";
for(i=9;i>=2;i--)
{
while(x.mod(BigInteger.valueOf(i)).compareTo(BigInteger.valueOf(0))==0)//就改了这一句就AC了!!!
{
                                                s=i+s;
x=x.divide(BigInteger.valueOf(i));
}
}
if(x.compareTo(BigInteger.ONE)!=0)
{
System.out.println("There is no such number.");
}
else
{
System.out.println(s);
}
}
}
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值