Eddy's picture(并查集+最小生成树)

171 篇文章 0 订阅
95 篇文章 0 订阅

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1162

Problem:

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7068    Accepted Submission(s): 3575


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1233  1217  1142  1875  1879 
 

My  code:


#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m,pre[500];
double ans;
struct edge{
int u;
int v;
double w;
}e[5000];
struct node{
double x;
double y;
}point[111];
bool cmp(edge a,edge b)
{
return a.w<b.w;
}
void init()
{
for(int i=0;i<n;i++)
pre[i]=i;
}
int fin(int root)
{
int son,tmp;
son=root;
while(root!=pre[root])
{
root=pre[root];
}
while(son!=root)
{
tmp=pre[son];
pre[son]=root;
son=tmp;
}
return root;
}
bool join(int root1,int root2)
{
int x;
int y;
x=fin(root1);
y=fin(root2);
if(x!=y)
{
pre[x]=y;
return true;
}
return false;
}
void kluscal(int n,int m)
{
sort(e+1,e+m+1,cmp);
ans=0;
for(int i=1;i<=m;i++)
{
if(join(e[i].u,e[i].v))
ans+=e[i].w;
}
}
double dis(double x1,double y1,double x2,double y2)
{
double d;
d=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
return d;
}
int main()
{
int i,j,cnt;
while(scanf("%d",&n)==1)
{
for(i=1;i<=n;i++)
{
scanf("%lf%lf",&point[i].x,&point[i].y);
}
cnt=0;
        for(i=2;i<=n;i++)
{
for(j=1;j<i;j++)
{
cnt++;
e[cnt].u=j;
e[cnt].v=i;
e[cnt].w=dis(point[i].x,point[i].y,point[j].x,point[j].y);
}
}
init();
kluscal(n,cnt);
printf("%.2lf\n",ans);
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值