Eeny Meeny Moo(经典Josephus变体(三大模板))

73 篇文章 0 订阅
6 篇文章 0 订阅

Link:http://poj.org/problem?id=2244



Eeny Meeny Moo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3203 Accepted: 2219

Description

Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow. 
To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order. 
Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected. 

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

Input

The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country. 
Input is terminated by a value of zero (0) for n.

Output

For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

Sample Input

3
4
5
6
7
8
9
10
11
12
0

Sample Output

2
5
2
4
3
11
2
3
8
16

Source


解题思想:有n个城市,第一个总是最先退出,相当于从第二个开始按1,2,……m,1,2……m这样报数,问题实际上可抽象成n-1个城市的Josephus问题,注意josephus思想是按0,1,……n-1编号的,又加上是从第二个城市开始报数,求得的最后一个城市的实际编号=Josephus方法求得的编号 +1+1。


效率较低版本:
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,m,f,a[200];
	for(i=3;i<=150;i++)
	{
		f=0;
		m=1;
		while(1)
		{
			for(j=2;j<=i-1;j++)
			{
				f=(f+m)%j;
			}
			if(f+1+1==2)
			{
				a[i]=m;
				break;
			}
			else
			{
				m++;
				f=0;
    			}
		}
	}


	int n;
	while(scanf("%d",&n)==1&&n)
	{
		printf("%d\n",a[n]);
	}
	return 0;
}





效率较高版本:


#include<iostream>
#include<algorithm>
using namespace std;
int josephus(int n,int m,int s)
{
	if(m==1)
		return (s+n-1)%n;
	for(int i=2;i<=n;i++)
	{
		s=(s+m)%i;
		if(i==n)
		break;
		if(s+m<i)
		{
			int x=(i-s)/(m-1);
			if(i+x<n)
			{
				i=i+x;
				s=(s+m*x)%i;
			}
			else
			{
				s=(s+m*(n-i))%n;
				break;
			}
		}
	}
	return s;
}
int main()
{
	int a[155],i,m,ret,n;
	for(i=2;i<=150;i++)
	{
		for(m=2;;m++)
		{
			ret=josephus(i,m,0);
			if(ret+1+1==2)
			{
				a[i]=m;
				break;
			}
		}
	}
	while(scanf("%d",&n)==1&&n)
	{
		printf("%d\n",a[n-1]);
	}
	return 0;
}



版本3:

解析:

递推公式为:

编号从0,1,……n-1,报数从1,2,……m的条件下:

f[i];  //第i轮杀掉 对应当前轮的编号为f[i]的人

f[0]=0;

f[i]=(f[i-1]+m-1)%(n-i+1);   (i>1  ,  总人数n, 则n-i+1为第i轮的人数)


#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int n,m,i,ans[200],f;
	for(n=2;n<=150;n++)
	{
		f=0;
		m=1;
       		for(i=1;i<=n-1;i++)//经过n-1轮后剩下最后一个
       		{
    			f=(f+m-1)%(n-i+1);

    			if(f+1+1==2)
    			{
  			  	i=0;
    				m++;
			}
    		}
    		ans[n]=m;//剩下的最后一个城市为原来的第二个
	}
	while(scanf("%d",&n)==1&&n)
	{
		printf("%d\n",ans[n-1]);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值