Missing number

181 篇文章 0 订阅
112 篇文章 0 订阅

Link:http://bestcoder.hdu.edu.cn/contests/contest_showproblem.php?cid=564&pid=1001




Missing number


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
There is a permutation without two numbers in it, and now you know what numbers the permutation has. Please find the two numbers it lose.
 
Input
  
  
There is a number T shows there are T test cases below. ( T10 )
For each test case , the first line contains a integers n , which means the number of numbers the permutation has. In following a line , there are n distinct postive integers.( 1n1,000 )
 
Output
  
  
For each case output two numbers , small number first.
 
Sample Input
  
  
2 3 3 4 5 1 1
 
Sample Output
  
  
1 2 2 3


#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
int a[1111],t[1111];
int main()
{
	int p,n;
	scanf("%d",&p);
	while(p--)
	{
		memset(t,0,sizeof(t));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			t[a[i]]=1;
		}
		int flag = 1;
		for(int i=1;i<=n+2;i++)
		{
			if(!t[i]&&flag){
				printf("%d ",i);
				flag=0;
			}
			else if(!t[i]&&!flag){
				printf("%d\n",i);
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值