hdu5289 Assignment(多校第一场第二题:RMQ+找规律或单调队列+找规律)

171 篇文章 0 订阅
102 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5289


Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1770    Accepted Submission(s): 854


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source
 



AC code1(RMQ+找规律):

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<map>
#include<vector>
#define LL long long
#define MAXN 1000010
using namespace std;
int num[MAXN];
int ma[100001][17],mi[100001][17];
int n,k,i,j;
LL ans=0;
//状态转移方程ma[j][i]=max(ma[j][i-1],ma[j+(1<<(i-1))][i-1])
//mi[j][i]=min(mi[j][i-1],mi[j+(1<<(i-1))][i-1])][i-1] 
void rmqinit() //j为区间起点,(1<<i)为区间长度 
{
	for(j=1;j<=n;j++)
	{
		ma[j][0]=mi[j][0]=num[j];
	}
	for(i=1;(1<<i)<=n;i++)//枚举区间长度为(1<<i) 
	{
		for(j=1;j+(1<<i)-1<=n;j++)//枚举区间起点 
		{
			ma[j][i]=max(ma[j][i-1],ma[j+(1<<(i-1))][i-1]);
			mi[j][i]=min(mi[j][i-1],mi[j+(1<<(i-1))][i-1]); 
		}
	}
}
int rmqmax(int l,int r)
{
	int k=(int)(log(1.0*(r-l+1))/log(2.0));
	return max(ma[l][k],ma[r-(1<<k)+1][k]);
}
int rmqmin(int l,int r)
{
	int k=(int)(log(1.0*(r-l+1))/log(2.0));
	return min(mi[l][k],mi[r-(1<<k)+1][k]);
}
int main()
{
	//printf("%I64d\n",1<<17);
	int T;
	while(scanf("%d",&T)!=EOF)
	{
		while(T--)
		{
			scanf("%d%d",&n,&k);
			for(i=1;i<=n;i++)
			{
				scanf("%d",&num[i]);
			}
			rmqinit();
			int st=1;
			int ed=1;
			ans=0;
			for(ed=1;ed<=n;ed++)
			{
			   //下面不能用if语句判断,必须用while,因为起点st对应的元素不一定就是当前区间最大值或最小值,
			  //且可以肯定的是,当前ed对应的元素一定是区间最大值或最小值,
			  //而区间最大与最小值元素之间的元素数可能不止一个 
				while(rmqmax(st,ed)-rmqmin(st,ed)>=k&&st<ed)
				{
					ans+=ed-st;
					st++;
				}
			}
			while(st<=n)
			{
				ans+=(ed-st);
				st++;
			}
			printf("%I64d\n",ans);
		}
	}
	return 0;
 } 


AC code2(单调队列+找规律):

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<map>
#include<vector>
#define LL long long
#define MAXN 1000010
using namespace std;
deque<int>deq1,deq2;//deq1为单调递增队列,deq2为单调递减队列
int num[MAXN];
int i,j,n,k;
LL ans=0;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&k);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&num[i]);
		}
		while(!deq1.empty()) deq1.pop_back();
		while(!deq2.empty()) deq2.pop_back();
		ans=0;
		int st=1;
		int ed=1;
		for(ed=1;ed<=n;ed++)
		{
			while(!deq1.empty()&&deq1.back()>num[ed]) deq1.pop_back();
			deq1.push_back(num[ed]);
			while(!deq2.empty()&&deq2.back()<num[ed]) deq2.pop_back();
			deq2.push_back(num[ed]);
			while(!deq1.empty()&&!deq2.empty()&&deq2.front()-deq1.front()>=k)
			{
				ans+=(ed-st);
				if(deq1.front()==num[st]) deq1.pop_front();
				if(deq2.front()==num[st]) deq2.pop_front();
				st++;
			}
		}
		while(st<=n)
		{
			ans+=(ed-st);
			st++;
		}
		printf("%I64d\n",ans);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值