Graph Coloring( DP优化的求最大团模板题:求原图的最大独立集和输出集合元素可转化为求补图的最大团顶点数+输出最大团元素)

102 篇文章 0 订阅
99 篇文章 0 订阅

link:http://poj.org/problem?id=1419


Graph Coloring
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4508 Accepted: 2063 Special Judge

Description

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black. 


 
Figure 1: An optimal graph with three black nodes 

Input

The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

Output

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5

Source



AC code:

#include<cstdio>
#include<cstring>
#define N 1010
/*
最大团 = 补图G的最大独立集数
———>最大独立集数 = 补图G'最大团
*/
//最大团模板
bool a[N][N];//a为图的邻接表(从1开始) 
int ans, cnt[N], group[N], n, m, vis[N];//ans表示最大团,cnt[N]表示当前最大团的节点数,group[N]用以寻找一个最大团集合 
bool dfs( int u, int pos )//u为当从前顶点开始深搜,pos为深搜深度(即当前深搜树所在第几层的位置) 
{
    int i, j;
    for( i = u+1; i <= n; i++)//按递增顺序枚举顶点 
	{
        if( cnt[i]+pos <= ans ) return 0;//剪枝 
        if( a[u][i] ) 
		{
             // 与目前团中元素比较,取 Non-N(i) 
            for( j = 0; j < pos; j++ ) if( !a[i][ vis[j] ] ) break; 
            if( j == pos )
			{     // 若为空,则皆与 i 相邻,则此时将i加入到 最大团中 
                vis[pos] = i;//深搜层次也就是最大团的顶点数目,vis[pos] = i表示当前第pos小的最大团元素为i(因为是按增顺序枚举顶点 ) 
                if( dfs( i, pos+1 ) ) return 1;    
            }    
        }
    }    
    if( pos > ans )
	{
            for( i = 0; i < pos; i++ )
                group[i] = vis[i]; // 更新最大团元素 
            ans = pos;
            return 1;    
    }    
    return 0;
} 
void maxclique()//求最大团 
{
    ans=-1;
    for(int i=n;i>0;i--)
    {
        vis[0]=i;
        dfs(i,1);
        cnt[i]=ans;
    }
}
int main()
{
	//freopen("D:\in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while( T-- )
	{
        scanf("%d%d",&n,&m );
        int x, y;
        memset( a, 0, sizeof(a));
        for(int i = 0; i < m; i++)
		{
            scanf("%d%d",&x,&y);
            a[x][y] = a[y][x] = 1;
        }
        //相邻顶点间有边相连,模型转换成求 无向图 最大独立集。 
		//要求原图的最大独立集,转化为求原图的补图的最大团(最大团顶点数量 = 补图的最大独立集)    
        for(int i = 1; i <= n; i++)//求原图的补图 
            for(int j = 1; j <= n; j++)
                if( i == j ) a[i][j] = 0;
                else    a[i][j] ^= 1;
        maxclique();//求最大团 
        if( ans < 0 ) ans = 0;//ans表示最大团
        printf("%d\n", ans );
        for(int i = 0; i < ans; i++)
            printf( i == 0 ? "%d" : " %d", group[i]);//group[N]用以寻找一个最大团集合 
        if( ans > 0 ) puts("");
    }        
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值