HDU5536 Chip Factory(异或最值问题——带删除01字典树)

171 篇文章 0 订阅
79 篇文章 0 订阅

 

Problem Link:http://acm.hdu.edu.cn/showproblem.php?pid=5536

Chip Factory

Time Limit: 18000/9000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 6521    Accepted Submission(s): 2936

Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

maxi,j,k(si+sj)⊕sk
which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2

3

1 2 3

3

100 200 300

Sample Output

6

400

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

 

AC code:

#include<bits/stdc++.h>
#define LL long long
using namespace std;
const int maxn=100010;
int n,m;
LL x,ans;
LL a[maxn*32];
int ch[maxn*32][2];
int val[maxn*32];//以根节点到当前结点作为前缀的总个数
int sz;

void init()
{
	sz=1;
	memset(ch,0,sizeof(ch));
	memset(val,0,sizeof(val));
}

void _insert(LL x)
{
	int u=0;
	for(int i=32;i>=0;i--)
	{
		int c=(x>>i)&1;
		if(!ch[u][c])
		{
			ch[u][c]=sz++;
		}
		u=ch[u][c];
		val[u]++;
	}
}

void _delete(LL x)
{
	int u=0;
	for(int i=32;i>=0;i--)
	{
		int c=(x>>i)&1;
		u=ch[u][c];
		--val[u];
	}
}

LL query(LL x)//输出最大异或值res或与x异或结果最大的元素maxx 
{
	LL res=0;//输出最大异或值 
	LL maxx=0;//输出与x异或结果最大的元素maxx 
	int u=0;
	for(int i=32;i>=0;i--)
	{
		int c=(x>>i)&1;
		if(ch[u][c^1] && val[ch[u][c^1]])
		{
			res+=(1<<i);//第i位与x第i位不同,该位异或结果为1 
			maxx+=((c^1)<<i);//maxx第i位为((c^1)<<i)
			u=ch[u][c^1];
		}
		else
		{
			u=ch[u][c];
			maxx+=((c)<<i);//maxx第i位为((c)<<i)
		}
	}
	return res;//输出最大异或值
	//return maxx; 
}

int main()
{
	//freopen("D:\\in.txt","r",stdin);
	int T;
	scanf("%d",&T);
	while(T--)
	{
		init();
		scanf("%d\n",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			_insert(a[i]);
		}
		ans=0;
		for(int i=1;i<=n;i++)
		{
			_delete(a[i]);
			for(int j=i+1;j<=n;j++)
			{
				_delete(a[j]);
				x=a[i]+a[j];
				ans=max(ans,query(x));
				_insert(a[j]);
			}
			_insert(a[i]);
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值