1046. Plane Spotting

1046. Plane Spotting

限制条件

时间限制: 1 秒, 内存限制: 32 兆

题目描述

Craig is fond of planes. Making photographs of planes forms a major part of his daily life. Since he tries to stimulate his social life, and since it’s quite a drive from his home to the airport, Craig tries to be very efficient by investigating what the optimal times are for his plane spotting. Together with some friends he has collected statistics of the number of passing planes in consecutive periods of fifteen minutes (which for obvious reasons we shall call ‘quarters’). In order to plan his trips as efficiently as possible, he is interested in the average number of planes over a certain time period. This way he will get the best return for the time invested. Furthermore, in order to plan his trips with his other activities, he wants to have a list of possible time periods to choose from. These time periods must be ordered such that the most preferable time period is at the top, followed by the next preferable time period, etc. etc. The following rules define which is the order between time periods:

1. A period has to consist of at least a certain number of quarters, since Craig will not drive three hours to be there for just one measly quarter. 
2. A period P1 is better than another period P2 if: 
* the number of planes per quarter in P1 is higher than in P2; 
* the numbers are equal but P1 is a longer period (more quarters); 
* the numbers are equal and they are equally long, but period P1 ends earlier.

Now Craig is not a clever programmer, so he needs someone who will write the good stuff: that means you. So, given input consisting of the number of planes per quarter and the requested number of periods, you will calculate the requested list of optimal periods. If not enough time periods exist which meet requirement 1, you should give only the allowed time periods.

输入格式

The input starts with a line containing the number of runs N. Next follows two lines for each run. The first line contains three numbers: the number of quarters (1–300), the number of requested best periods (1–100) and the minimum number of quarters Craig wants to spend spotting planes (1–300). The sec-nod line contains one number per quarter, describing for each quarter the observed number of planes. The airport can handle a maximum of 200 planes per quarter.

输出格式

The output contains the following results for every run: 

* A line containing the text “Result for run <N>:” where <N> is the index of the run. 

* One line for every requested period: “<F>-<L>” where <F> is first quarter and <L> is the last quarter of the period. The numbering of quarters starts at 1. The output must be ordered such that the most preferable period is at the top.

样例输入

3
10 5 5
1 5 0 2 1 4 2 5 0 2 
10 3 5
10 3 1 4 2 6 3 0 8 0 
5 5 5
1 2 3 4 5

样例输出

Result for run 1:
4-8
2-8
6-10
1-8
2-6
Result for run 2:
1-6
1-7
1-9
Result for run 3:
1-5

结构体数据的比较。自己写的排序超时了,所以用algorithm里的sort好了…

AC:

#include <iostream>
#include <algorithm>

using namespace std;

struct plan{
	int first;
	int last;
	double ppq;
};

bool compare(plan p1, plan p2) {
	if(p1.ppq > p2.ppq) {
		return true;
	}
	if(p1.ppq == p2.ppq && (p1.last - p1.first > p2.last - p2.first)) {
		return true;
	}
	if(p1.ppq == p2.ppq && (p1.last - p1.first == p2.last - p2.first) && p1.last < p2.last) {
		return true;
	}
	return false;
}

int main() {
	int tests;
	cin >> tests;
	for(int c = 1; c <= tests; c++) {
		int quar, methods, min;
		cin >> quar >> methods >> min;
		int planes[quar];
		for(int i = 0; i < quar; i++) {
			cin >> planes[i];
		}
		struct plan runs[100000];
		int count = 0;
		for(int size = min; size <= quar; size++) {
			for(int i = 0; i+size-1 < quar; i++) {
				double pl = 0;
				for(int j = i; j <= i+size-1; j++) {
					pl += planes[j];
				}
				runs[count].first = i+1;
				runs[count].last = i+size;
				runs[count].ppq = pl / size;
				count++;
			}
		}
		
		sort(runs, runs+count, compare);
		
		cout << "Result for run " << c << ":" << endl;
		for(int i = 0; i < methods && i < count; i++) {
			cout << runs[i].first << '-' << runs[i].last << endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值