I - Counting Triangles

I - Counting Triangles

You are given N sticks having distinct lengths; you have to form some triangles using the sticks. A triangle is valid if its area is positive. Your task is to find the number of ways you can form a valid triangle using the sticks.


Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with a line containing an integer N (3 ≤ N ≤ 2000). The next line contains N integers denoting the lengths of the sticks. You can assume that the lengths are distinct and each length lies in the range [1, 109].

Output

For each case, print the case number and the total number of ways a valid triangle can be formed.

Sample Input

3

5

3 12 5 4 9

6

1 2 3 4 5 6

4

100 211 212 121

Sample Output

Case 1: 3

Case 2: 7

Case 3: 4

题意:给出一堆数据,判断能构成的三角形数目。

题解:一开始我用三重循环做,但是超时。后来网上查到了一种二分查找涵数lower_bond 和 upper_bond。能通过二分查找的方式找出一个有序数组中不小于给定数的下标和大于给定数的下标。


#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int T;
    int i,j;
    int count = 0;
    int a[2005];
    scanf("%d",&T);
    while(T--)
    {
        int lf,rh;
        int N;
        count++;
        scanf("%d",&N);
        for(i = 0;i < N;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a + N);
        int ans = 0;
        for(i = 0;i < N - 2;i++)
        {
            for(j = i + 1;j < N - 1;j++)
            {
                lf = a[j] - a[i] + 1;
                rh = a[j] + a[i] - 1;

                lf = lower_bound(a, a + N, lf) - a;
                rh = upper_bound(a + lf, a + N, rh) - a - 1;

                if(lf <= j)
                {
                    lf = j + 1;
                }
                if(rh <= j)
                {
                    continue;
                }
                if(lf <= rh)
                {
                    ans += rh - lf + 1;
                }
            }
        }
        printf("Case %d: %d\n",count,ans);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值