Charm Bracelet 01背包

A - Charm Bracelet

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.


Input


* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23

题意:给N个物品1个容量为M的背包,每个物品的容量和价值都不同,问再不超过背包容量的情况下,如何取得最大的价值,每个物品只能拿一次。

题解:01背包问题,用动态规划。我开始用的二维数组结果超内存了,这题应该用一维数组。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 3500;
const int maxt = 14000;
int dp[maxt];
int w[maxn];
int v[maxn];

int main()
{
    int i,j;
    int N,M;
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&N,&M);
    for(i = 1;i <= N;i++)
    {
        scanf("%d%d",&w[i],&v[i]);
    }
    for(i = 1;i <= N;i++)
    {
        for(j = M;j >= w[i];j--)
        {
            dp[j] = max(dp[j - w[i]] + v[i],dp[j]);
        }
    }
    printf("%d\n",dp[M]);

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值