4131:Charm Bracelet 01背包问题

总时间限制:
1000ms
内存限制:
65536kB

描述

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a ‘desirability’ factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
输出
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

输入:第一行,两个整数N,M,分别是:有多少东西,有多少空间。后面的行:每行两个数字,第一个是这个东西的大小,第二个是这个东西的价值,一共N行。

输出:包里能装的最多的价值。

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23
动态规划问题,用一行和背包容量相同的向量存储在j位置上最大的价值,可以选择在这个位置上放i物品,也可以选择不放,更新的时候,从后向前更新,如果发现更新之后的值更好,那么就更新
#include <iostream>
#include <vector>
using namespace std;
int main()
{
    int n, m;
    vector<int> w_v;
    vector<int> d_v;
    //n:有少个东西,m个容量
    cin>>n>>m;
    int w, d;
    vector<int> dp;
    for (int i = 0; i < n; ++i) {
        cin>>w>>d;
        w_v.push_back(w);
        d_v.push_back(d);
    }

    //初始化数组
    for (int i = 0; i <= m; ++i) {
        dp.push_back(0);
    }

    for (int i = 1; i <= n; ++i) {
        for (int j = m; j >= w_v[i-1]; --j) {
            //在j大小的空间里放第i个东西
            dp[j] = max(dp[j], d_v[i-1]+dp[j-w_v[i-1]]);
        }
    }
    cout<<dp[m]<<endl;
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值