Eddy's 洗牌问题
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5139 Accepted Submission(s): 3424
Problem Description
Eddy是个ACMer,他不仅喜欢做ACM题,而且对于纸牌也有一定的研究,他在无聊时研究发现,如果他有2N张牌,编号为1,2,3..n,n+1,..2n。这也是最初的牌的顺序。通过一次洗牌可以把牌的序列变为n+1,1,n+2,2,n+3,3,n+4,4..2n,n。那么可以证明,对于任意自然数N,都可以在经过M次洗牌后第一次重新得到初始的顺序。编程对于小于100000的自然数N,求出M的值。
Input
每行一个整数N
Output
输出与之对应的M
Sample Input
20 1
Sample Output
20 2
题解:这是道找规律的题,只要1回到起始位置,那么其他的数都会回到起始位置。那么问题就变成了需要洗几次牌使得1回到位置1了,对于1位置的变化有如下规律:
对于1的位置k:
1.如果1的位置小于等于N,那么1的下一个位置为2 * k。
2.如果1的位置大于N,那么1的下一个位置为(k - N) * 2 - 1。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1e5 + 5;
int main()
{
int N;
int ans;
int k;
while(scanf("%d",&N) != EOF)
{
ans = 0;
k = 1;
k *= 2;
ans++;
while(k != 1)
{
if(k <= N)
{
k *= 2;
}
else
{
k = (k - N) * 2 - 1;
}
ans++;
}
printf("%d\n",ans);
}
return 0;
}