HDU1026 Ignatius and the Princess I(BFS+优先队列)

127 篇文章 0 订阅
85 篇文章 2 订阅

HDU1026 Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output

For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
..XX1.
2…X.
…XX.
XXXXX.

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

问题简述

典型的bfs+打印路径+优先队列问题。有一个N*M大小的迷宫,英雄你要从(0,0)进入,公主在(N-1,M-1)的位置,其中在路途中会有怪物(用数字1-9来表示并且hp为1-9,杀死它们需要hp秒),’X’表示不能走,’.’表示可以随意走动,现在要求你最短的时间来拯救公主。

问题难点

在简单的bfs基础上加入了时间的问题,所以在用bfs的时候需要考虑优先问题,因为如果只是广度来搜索的话,所用时间不一定是最短的。所以用优先队列来解决,让用时少的先出列。

struct node{
    int x, y, sec, prex, prey;
    friend bool operator < (node n1, node n2){
        return n2.sec < n1.sec;
    }
}note[N][N];

还有就是打印路径问题,这个可以用dfs来搜索前驱点就好了。

void print(int x, int y)
{
    if (x == 0 && y == 0)
        return;

    int prex = note[x][y].prex;
    int prey = note[x][y].prey;

    print(prex, prey);

    int prel = note[prex][prey].sec;
    int len = note[x][y].sec;
    printf("%ds:(%d,%d)->(%d,%d)\n", prel + 1, prex, prey, x, y);
    for (int i = prel + 2; i <= len; i++)
    {
        printf("%ds:FIGHT AT (%d,%d)\n", i, x, y);
    }
}

好,接下来是AC代码

#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
#define N 111
using namespace std;

char a[N][N];
int book[N][N], nxt[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
int n,m;

struct node{
    int x, y, sec, prex, prey;
    friend bool operator < (node n1, node n2){
        return n2.sec < n1.sec;
    }
}note[N][N];

int judge(int x, int y)
{
    if(book[x][y]==1)
    return 0;
    if(x<0||x>=n||y<0||y>=m)
    return 0;
    if(a[x][y]=='X')
    return 0;
    return 1;
}

int bfs()
{
    priority_queue <node> q;    //定义一个优先队列
    node cur;
    note[0][0].x = note[0][0].y = 0;   //初始化
    note[0][0].sec = 0;
    book[0][0] = 1;
    q.push(note[0][0]);    //第一个元素入队
    while(!q.empty())
    {
        cur = q.top();    //队首出队
        q.pop();
        if(cur.x==n-1 && cur.y==m-1){    //救到公主
            return 1;
        }
        for(int i=0;i<4;i++){
            int nx = cur.x + nxt[i][0];
            int ny = cur.y + nxt[i][1];
            if( judge(nx,ny) == 0)    //判定
                continue;
            //可以走
            book[nx][ny] = 1;
            if( '1'<=a[nx][ny] && a[nx][ny]<='9' ){    //如果这一处有怪物
                int hp = a[nx][ny] - '0';
                note[nx][ny].sec = cur.sec + hp + 1;
                note[nx][ny].prex = cur.x;
                note[nx][ny].prey = cur.y;
                note[nx][ny].x = nx;
                note[nx][ny].y = ny;
            }else{                                  //没有怪物
                note[nx][ny].sec = cur.sec + 1;
                note[nx][ny].prex = cur.x;
                note[nx][ny].prey = cur.y;
                note[nx][ny].x = nx;
                note[nx][ny].y = ny;
            }
            q.push(note[nx][ny]);
        }
    }
    return 0;
}

void print(int x, int y)   //dfs打印路径
{
    if (x == 0 && y == 0)
        return;

    int prex = note[x][y].prex;
    int prey = note[x][y].prey;

    print(prex, prey);

    int prel = note[prex][prey].sec;
    int len = note[x][y].sec;
    printf("%ds:(%d,%d)->(%d,%d)\n", prel + 1, prex, prey, x, y);
    for (int i = prel + 2; i <= len; i++)
    {
        printf("%ds:FIGHT AT (%d,%d)\n", i, x, y);
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(book,0,sizeof(book));
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf(" %c",&a[i][j]);
            }
        }
        int ans = bfs();
        if(ans==0) {
            printf("God please help our poor hero.\n");
        } else {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",note[n-1][m-1].sec);
            print(n-1,m-1);
        }
        printf("FINISH\n");
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值