POJ - 2031 Building a Space Station(最小生成树 prim算法)

Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11014 Accepted: 5074

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

Code

#include <cstdio>
#include <cstring>
#include <cmath>
#define N 110
#define INF 0x3f3f3f3f

using namespace std;

struct node
{
    double x, y, z, r;
} s[N];

double map[N][N];
double dis[N];
int vis[N];

double distance(int i, int j)
{
    double t = sqrt((s[i].x - s[j].x) * (s[i].x - s[j].x) + (s[i].y - s[j].y) * (s[i].y - s[j].y) + (s[i].z - s[j].z) * (s[i].z - s[j].z));
    ///两球半径之和大于球心距离,为包含或相交状态
    if(s[i].r + s[j].r > t)
        return 0;
    return t - s[i].r - s[j].r;
}

void prim(int n)
{
    int i,j,pos;
    double min;
    float ans = 0.0;
    for(i=1; i<=n; i++)
    {
        dis[i] = map[1][i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=1; i<=n; i++)
    {
        min = INF * 1.0;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] < min)
            {
                min = dis[j];
                pos = j;
            }
        }
        if(min != INF * 1.0)
        {
            ans += min;
            vis[pos] = 1;
            for(j=1; j<=n; j++)
            {
                if(!vis[j] && dis[j] > map[pos][j])
                {
                    dis[j] = map[pos][j];
                }
            }
        }
    }
    ///用lf会WA...
    printf("%.3f\n",ans);
}

int main()
{
    int i,j,n;
    while(~scanf("%d",&n) && n)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%lf %lf %lf %lf",&s[i].x,&s[i].y,&s[i].z,&s[i].r);
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                map[i][j] = distance(i,j);
            }
        }
        prim(n);
    }
    return 0;
}

反思:

题目大意:一个空间站由许多球形的单元构成,要求设计空间站的走廊,使所有的球形舱室可达,并使走廊总长最短。任意两个球形舱室只要相交(或者包含)就算作连通,走廊只能空间相交(即平面不相交,不能在中间拐弯到另一个舱室)。第一行给出舱室数量,接下来n行分别是舱室的x,y,z轴坐标和半径r,当n的输入为0时停止。因为给出的是坐标,不能直接存图,通过求两点之间的距离来存图,如果两个舱室相交则距离为0,否则距离为坐标距离和两球心半径之和的差。注意距离为浮点数。之后最小生成树prim即可。比较迷的是如果ans是double类型,用%lf输出会WA,改成float类型和%f就AC了……debug了一下午终于找出来了QWQ,题目的误差是0.001之内,难道是double精确过头了吗⊙▽⊙……?

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值