ZOJ - 1586 QS Network(最小生成树 prim算法)

QS Network

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

Code
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 1010
#define INF 0x3f3f3f3f

using namespace std;

int map[N][N];  ///保存每个QS之间的电缆的价格
int adp[N];     ///保存每个QS网络适配器的价格
int dis[N];
int vis[N];

void prim(int n)
{
    int i,j,pos,min,ans = 0;
    ///两个QS建立联系时,需要两个适配器
    for(i=1; i<=n; i++)
    {
        dis[i] = map[1][i] + adp[1] + adp[i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=1; i<=n; i++)
    {
        min = INF;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] < min)
            {
                min = dis[j];
                pos = j;
            }
        }
        if(min != INF)
        {
            ans += min;
            vis[pos] = 1;
            for(j=1; j<=n; j++)
            {
                if(!vis[j] && dis[j] > map[pos][j] + adp[j] + adp[pos])
                {
                    dis[j] = map[pos][j] + adp[j] + adp[pos];
                }
            }
        }
    }
    printf("%d\n",ans);
}

int main()
{
    int t,i,j,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++)
        {
            scanf("%d",&adp[i]);
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        prim(n);
    }
    return 0;
}
反思:

题目大意:在星球w-503上,有种智能生物-QS通过网络通信。两个QS之间通信需要网络适配器和网络电缆。网络适配器是单向链接的(有向图),而且不同QS之间需要的网络适配器不同,要求让所有QS通信的最低成本。第一行是数据组数t,每组数据中,第一行是QS数量n,第二行有n个数据,代表每个QS的网络适配器的价格,剩下的几行是网络电缆价格的邻接矩阵。和一般的prim略有些不同,要在求电缆最低价格的同时算上网络适配器的价格(初始化和更新dis数组时),因为是单向的还得算上两个……不过还是最小生成树模板题。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值