poj3723 Conscription Kruscal算法最大生成森林

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9902 Accepted: 3502

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223



根据题意,只要用排序优化的Kruscal算法求出带有最大权值和的生成森林,森林的权值和是ans,则(N + M) * 10000 - ans即为最小cost


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>

using namespace std;

struct Edge {
	int u, v, w;
	Edge() {}
	Edge(int u, int v, int w) : u(u), v(v), w(w) {}
};

vector<Edge> edges;

int N, M, R;
int p[20010];

bool cmp(const Edge a, const Edge b) {
	return a.w > b.w;  //从大到小排序
}

int Find(int x) {  //并查集
	return p[x] == x ? x : p[x] = Find(p[x]);
}

int Kruscal() {
	for (int i = 0; i < N + M; i++) p[i] = i;
	sort(edges.begin(), edges.end(), cmp);
	int ans = 0;
	for (int i = 0; i < edges.size(); i++) {
		int x = Find(edges[i].u), y = Find(edges[i].v);
		if (x != y) {
			p[y] = x;
			ans += edges[i].w;
		}
	}
	return (N + M) * 10000 - ans;
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--) {
		edges.clear();
		scanf("%d%d%d", &N, &M, &R);
		int u, v, w;
		for (int i = 0; i < R; i++) {
			scanf("%d%d%d", &u, &v, &w);
			//为了分别girl和boy,将v平移N,这么做放在一个数组里也方便计算并查集
			edges.push_back(Edge(u, v + N, w));
		}
		printf("%d\n", Kruscal());
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值