hdu1058 Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22914    Accepted Submission(s): 10025


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.


刚开始想用个类似于BFS的方法对2,3,5,7四种倍数进行搜索,队列用优先队列来保证次序,有一个set来去重,结果好像超时两三秒得,没敢交


超时代码


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <set>

using namespace std;

typedef long long ll;

struct node {
	ll x;
	bool operator < (const node& on) const {
		return x > on.x;
	}
	node(ll x) : x(x) {}
};

const int maxn = 5842, muti[] = {2, 3, 5, 7};
ll ans[maxn * 2];
int len;

int main()
{
	priority_queue<node> Q;
	set<ll> s;
	Q.push(node(1));
	s.insert(1);
	int cnt = 0;
	while (cnt <= 6600) {
		ll t = Q.top().x; Q.pop();
		for (int i = 0; i < 4; i++) {
			ll tt = t * muti[i];
			if (s.count(tt) == 0) {
				s.insert(tt);
				++cnt;
				Q.push(node(tt));
			}
		}
	}
	len = 0;
	for (set<ll>::iterator i = s.begin(); i != s.end(); i++) {
		ans[++len] = *i;
	}
	int n;
	while (~scanf("%d", &n) && n) {
		if (n % 10 == 1 && n % 100 != 11) {
			printf("The %dst humble number is %d.\n", n, ans[n]);
		}
		else if (n % 10 == 2 && n % 100 != 12) {
			printf("The %dnd humble number is %d.\n", n, ans[n]);
		}
		else if (n % 10 == 3 && n % 100 != 13) {
			printf("The %drd humble number is %d.\n", n, ans[n]);
		}
		else {
			printf("The %dth humble number is %d.\n", n, ans[n]);
		}
	}
	return 0;
}



正确代码,有点线程并发的感觉有木有。。。


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int min4(int a, int b, int c, int d) {
    return min(min(a, b), min(c, d));
}

int main()
{
    int n, a[5900];
    int p2, p3, p5, p7; 
    p2 = p3 = p5 = p7 = 1; //分别存最小的下标
    a[1] = 1;
    n = 1;
    while(a[n] < 2000000000) {
        a[++n] = min4(a[p2] * 2, a[p3] * 3, a[p5] * 5, a[p7] * 7); 
        if (a[n] == a[p2] * 2) p2++;
        if (a[n] == a[p3] * 3) p3++;
        if (a[n] == a[p5] * 5) p5++;
        if (a[n] == a[p7] * 7) p7++;
    }
    while(~scanf("%d", &n) && n) {
        if (n % 10 == 1 && n % 100 != 11) {
            printf("The %dst humble number is %d.\n", n, a[n]);
        } else if (n % 10 == 2 && n % 100 != 12) {
            printf("The %dnd humble number is %d.\n", n, a[n]);
        } else if (n % 10 == 3 && n % 100 != 13) {
            printf("The %drd humble number is %d.\n", n, a[n]);
        } else {
            printf("The %dth humble number is %d.\n", n, a[n]);
        }   
    }   
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值