hdu5806 NanoApe Loves Sequence Ⅱ 前缀和 + 二分

NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 662    Accepted Submission(s): 315


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with  n  numbers and a number  m  on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the  k -th largest number in the subsequence is no less than  m .

Note : The length of the subsequence must be no less than  k .
 

Input
The first line of the input contains an integer  T , denoting the number of test cases.

In each test case, the first line of the input contains three integers  n,m,k .

The second line of the input contains  n  integers  A1,A2,...,An , denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

Output
For each test case, print a line with one integer, denoting the answer.
 

Sample Input
  
  
1 7 4 2 4 2 7 7 6 5 1
 

Sample Output
  
  
18
 

Source


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

typedef long long ll;
ll n, m, k, a[200005], sum[200005], cnt, ans;

int main()
{
	ll T;
	cin >> T;
	while (T--) {
		scanf("%I64d%I64d%I64d", &n, &m, &k);
		sum[0] = a[0] = 0;
		//算到i为止(包括i)有多少个大于等于m的数
		//可知sum是不减的,可以用二分
		for (ll i = 1; i <= n; i++) {
			scanf("%I64d", &a[i]);
			sum[i] = (a[i] >= m ? sum[i - 1] + 1 : sum[i - 1]);
		}
		ans = 0;
		for (ll i = 1; i <= n; i++) {
			//core-debug l = i + k - 1 not l = i + 1 when k == 1
			ll l = i + k - 1, r = n, mid;
			while (l <= r) {
				mid = (l + r) / 2;
				ll t = sum[mid] - sum[i - 1];
				if (t >= k) {
					r = mid - 1;
				}
				else {
					l = mid + 1;
				}
			}
			if (l <= n) //二分找不到的情况,即所有都小
				ans += (n - l + 1);
		}
		printf("%I64d\n", ans);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值