最短路之SPFA

POJ-2387
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

一开始看这样的题,果断用迪杰斯特拉算法,后来觉得这个算法写起来过于麻烦,而且有好多弊端,比如不能处理权值为负,就又去看了看Floyd,但是Floyd算法时间复杂度是O(n^3),虽然能处理带权值为负,但时间复杂度的性质决定不能处理太多的数据,否则对于算法那一秒来说肯定超时,就去学习了一下SPFA,看了网上好多博客大佬都说这个算法高效,好用,而且能处理权值为负的图,各种好处(但是不能处理有负环的图),就去学习了一下。一开始因为对于数组模拟链表的不熟练,一直看不懂数组的作用,又特意去学习了一下,说真的,数组模拟真的不如用指针来实现。好了,话不多说了,直接上代码吧,这个题是一个水题,拿出来就是为了熟练一下SPFA算法

#include<stdio.h>
#include<queue>
#include<string.h>
#define inf 0x3f3f3f3f   
using namespace std;  
int n,m,len;  
struct node  
{  
    int u,v,w;  
}ans[4005];  
int first[4005];
int next[4005];
int dis[4005];
int vis[4005];  
void add(int u,int v,int w)  //数组模拟链表,next数组存储位置,手动实现一下数据就懂了
{  
    ans[len].u=u;
	ans[len].v=v;
	ans[len].w=w;  
    next[len]=first[u];  
    first[u]=len++;  
}  
void spfa(int st)  
{  
    dis[st]=0;  
    vis[st]=1;  
    queue<int>q;  
    q.push(st);  
    while(!q.empty())  
    {  
        st=q.front();  
        q.pop();  
        vis[st]=0;     //每次清0,防止在前面有更短的路径被错过
        for(int i=first[st];i!=-1;i=next[i])  
        {  
            if(dis[ans[i].v]>dis[st]+ans[i].w)  
            {  
                dis[ans[i].v]=dis[st]+ans[i].w;  
                if(!vis[ans[i].v])  
                {  
                    vis[ans[i].v]=1;  
                    q.push(ans[i].v);  
                }  
            }  
        }  
    }  
  
}  
int main()  
{  
    int x,y,z;  
    while(scanf("%d%d",&m,&n)==2)  
    {  
    	len=1;
        memset(dis,inf,sizeof(dis));
		memset(vis,0,sizeof(vis));
		memset(first,-1,sizeof(first));
		memset(next,-1,sizeof(next));    
        for(int i=1;i<=m;i++)  
        {  
            scanf("%d%d%d",&x,&y,&z);  
            add(x,y,z);  
            add(y,x,z);   
        }  
        spfa(1);  
        printf("%d\n",dis[n]);  
    }  
    return 0;  
} 
对了,这个题唯一的一个坑点就是重边的问题,用迪杰斯特拉的朋友要注意一下,可以用判断来选择是否替换原来的边,用SPFA的则可以不去考虑,SPFA用的是队列来实现,想学的朋友可以去学习一下队列和优先队列,都是很有用的数据结构。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值